Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Pausezeit mit Wennfunktion

Pausezeit mit Wennfunktion
18.09.2013 12:32:46
Andreas
Hallo Forum,
Ich nutze ein Stundenplan mit folgender Formel;
=WENN(ODER(D15="U";D15="K";D15="F");6,66666666666666;(E15-D15))
Ich verwende die Zellenformatierung ZAHL und nicht UHRZEIT, aufgrund der Eingaben.
Soweit so gut, meine Stundendauer wird richtig berechnet. Jetzt kommt leider hinzu das wenn die Arbeitszeit länger als 6 Stunden dauert eine halbe Stunde Pause abgezogen werden soll.
Daraufhin habe ich mit einer Hilfspalte und folgender Formel gearbeitet
=WENN(SUMME(O15:T15)=0;"";WENN(O15>6;O15-0,5;C15-B15))
Das Problem jetzt ist, wenn ich U = Urlaub eingebe, dann zieht er mir die halbe Stunde logischer Weise auch davon ab, weil es 6,666666 Stunden sind.
Ich bin daran gescheitert die Formeln zusammen zu führen.
Letztendlich soll wenn ich über 6 Stunden komme minus 0,5 berechnet werden, aber wenn U, K, oder F verwendet wird 6,6666 bleiben.
Hoffe habe mich verständlich ausgedrückt!
MfG Andreas

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Pausezeit mit Wennfunktion
18.09.2013 12:42:23
Thorsten_Z
Hallo Andreas,
wie wäre es ohne Hilfsspalte und dann so:
=WENN(ODER(D15="U";D15="K";D15="F");6,66666666666666;WENN((E15-D15)>6;(E15-D15)-0,5;(E15-D15))) 

Gruß
Thorsten

AW: Pausezeit mit Wennfunktion
18.09.2013 13:12:01
Andreas
Hallo Thorsten,
vielen Dank für deine Hilfe, klappt genau wie gewünscht! Die schnelle und kompetente Hilfe hier ist immer wieder super!!
Gruß Andreas

Noch ein kleiner Nachtrag...
18.09.2013 13:20:12
Thorsten_Z
...erstmal danke für die Rückmeldung.
Ich habe gesehen, dass du für "F" "K" und "U" 6,666 also eine Zahl angibst. Dann rechne doch für die Zeitergebnisse auch mit Zahlen. Dann so.
=WENN(ODER(D15="U";D15="K";D15="F");6,66666666666666;WENN(((E15-D15)*24)>6;((E15-D15)*24)-0,5; (E15-D15)*24)) 
Gruß
Thorsten

Anzeige
oder so...
18.09.2013 14:02:31
ingoG
Hallo Andreas,
folgende Formelnkannst Du ebenfalls benutzen:
der Unterschied ist jeweils die behandlung bei Arbeitszeiten zwischen 6:00 und 6:30 Stunden:
F1:
=WENN(ODER(D15="U";D15="K";D15="F");6,66666666666666;(E15-D15)-MIN((E15-D15)>0,25;0,5/24))
F2:
=WENN(ODER(D15="U";D15="K";D15="F");6,66666666666666;(E15-D15)-MIN((E15-D15)>0,25; MIN(ABS(E15-D15-0,25);0,5/24))) 

__Z1___Z2___F1___F2__
08:00 13:00 05:00 05:00
08:00 13:10 05:10 05:10
08:00 13:20 05:20 05:20
08:00 13:30 05:30 05:30
08:00 13:40 05:40 05:40
08:00 13:50 05:50 05:50
08:00 14:00 06:00 06:00
08:00 14:10 05:40 06:00
08:00 14:20 05:50 06:00

08:00 14:30 06:00 06:00
08:00 14:40 06:10 06:10
08:00 14:50 06:20 06:20
08:00 15:00 06:30 06:30
08:00 15:10 06:40 06:40
08:00 15:20 06:50 06:50
ich hoffe, das hilft Dir weiter
Gruß Ingo

Anzeige
AW: Noch ein kleiner Nachtrag...
18.09.2013 14:36:57
Andreas
Ich bin der Meinung, bei so guter Unterstützung und Hilfe hier im Forum, ist eine Rückmeldung doch wohl selbstverständlich...Danke mochmal, ich probiere die andere Formel mal!
Gruß Andreas

AW: Noch ein kleiner Nachtrag...
18.09.2013 14:38:19
Andreas
Danke auch für deinen Beitrag und Lösungsvorschlag, Ingo!
Gruß Andreas

328 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige