Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählehoch, wenn ein Bestimmter Inhalt

Zählehoch, wenn ein Bestimmter Inhalt
26.10.2012 14:20:24
Justin
Hallo Liebes Forum,
etwas komplizierter ist meine Frage an euch heute...
Im Tabellenblatt 2 habe ich eine Übersicht, in der die Spalte Anzahl gefüllt bzw. hochgezählt werden soll( ein X sagt ob hochgezählt werden soll oder nicht).
Informationen liegen im Tabellenblatt 1 inder Spalte Profil.
Beispiel:
Im Tabellenblatt 2 Zeile 1 steht ein A (bei Profil)
Also soll im Tabellenblatt 1 bei Produkt 1 / 2 / 3 / 7 / 8 hochgezählt werden
Hier eine Beispiel-Datei..
https://www.herber.de/bbs/user/82330.xls
Ps: Mittels eines Vba Codes wollte ich das Umsetzen
Ich weis nicht so recht wie ich anfangen soll, wür ideen bin ich sehr dankbar...

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
ZÄHLENWENN und SUMMENPRODUKT
26.10.2012 16:51:58
Erich
Hi Justin,
wozu willst du hier VBA bemühen? Das geht per Formel einfacher:
 EFGHI
2AnzahlyABC
339 XXX
439 XXX
539 XXX
626  XX
726  XX
813   X
939 XXX
1039 XXX

Formeln der Tabelle
ZelleFormel
E3=SUMMENPRODUKT((G3:I3="x")*(Sheet1!F$2:F$40=G$2:G$2))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Was in Sheet2!B3:B10 steht (als Produkt), spielt überhaupt keine Rolle.
Dein Beispiel ist übrigens so gewählt, dass man möglichst nicht erkennen kann, wie gezählt wird, ob die Formeln stimmen.
Geschickter wäre z. B. eine kürzere Tabelle in Sheet1 gewesen, in der z. B. 5 A's, 3 B's, kein C und ein D stehen.
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
AW: ZÄHLENWENN und SUMMENPRODUKT
30.10.2012 14:24:03
Justin
Ich will ein Vba-Code per Knopfdruck ( in diesem Falle per Calculate ) Ablaufen lassen... damit der Benutzer möglichst wenig komplexität erkennt... es soll so einfach wie möglich sein...
Ich habe mich eventuell nicht richtig ausgedrückt, du hast recht das man nicht erkennt wie man Zählen soll... ich werde mich mal mit der Formel des Summenproduktes auseinandersetzen müssen... Vielen Dank erstmal für die Formel ich studiere etwas an ihr..

303 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige