Zellenfixierung mit WENN Funktion definieren

Bild

Betrifft: Zellenfixierung mit WENN Funktion definieren
von: Simon T.
Geschrieben am: 14.10.2015 09:57:12

Hallo,
hat jemand vlt. eine Idee wie ich den festen Zellenbezug mit einer Wennfunktion definieren kann?
BSP:
SUMME($G$(WENN(Q2="erste Zelle";P2;P3):G2)/SUMME($O$(WENN(Q2="erste Zelle";P2;P3):O2
Ursprung:
=SUMME($G$2:G2)/SUMME($O$2:O2)
Die fette 2 soll anhand einer Wennfunktion ermittelt werden.
Vielen Dank im Forraus!

Bild

Betrifft: AW: mit INDEX() möglich ...
von: ... neopa C
Geschrieben am: 14.10.2015 10:05:04
Hallo Simon,
... z.B. so =SUMME(INDEX(G:G;WENN(....)):G2/INDEX(O:O;WENN(....)):O2)
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit INDEX() möglich ...
von: Simon T.
Geschrieben am: 14.10.2015 10:23:53
Arbeitsdatei: https://www.herber.de/bbs/user/100773.xlsx
Vielen Dank! Leider ist ein weiterer Fehler aufgetaucht.
SUMME(INDEX(G:G;WENN(Q2="erste Zelle";P2;P3)):G2/INDEX(O:O;WENN(Q2="erste Zelle";P2;P3)):O2)
Das fette P ist auch eine Variable.
immer wenn in Zeile Q="erste Zelle" steht soll das P durch die dazugehörige Zahl in P ersetzt werden.
BSP:
Q="erste Zelle" (Q6) soll P duch P(P6) ersetzt werden. immer dann wenn ein Wechsel in Q auf eine neue "erste Zeile" stattfinden muss P angepasst werden.
Spalte R stehen die Werde die duch die Formel errechnet werden sollen als Kontrolle.
Ist meine Schilderung verständlich?

Bild

Betrifft: AW: in Deiner Datei fehlen noch ...
von: ... neopa C
Geschrieben am: 14.10.2015 12:18:54
Hallo Simon,
... die Datenwerte in Spalte O, so dass eine Ermittlung mit Deiner Formel immer nur Fehlerwerte ergeben würden.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: in Deiner Datei fehlen noch ...
von: Simon T.
Geschrieben am: 14.10.2015 12:28:15
Achso,
in der Originaldatei sind dort Werte eingetragen. Habe eine Anonymisierte Version hoch geladen wo ich die Spaolte wohl gelöscht habe...
Habe es aktualisiert.
https://www.herber.de/bbs/user/100779.xlsx

Bild

Betrifft: AW: nun bedarf es noch Deiner Definition ...
von: ... neopa C
Geschrieben am: 14.10.2015 12:55:32
Hallo Simon,
... wie Du auf auf Ergebnisse in Spalte R kommst, wo in Spalte Q nicht "erste Zelle" steht.
Nach Deiner momentanen Vorgabe würde die Formel in S2 wie folgt aussehen:
=SUMME((INDEX(G:G;WENN(Q2="erste Zelle";P2;P3)):G2))/SUMME((INDEX(O:O;WENN(Q2="erste Zelle";P2;P3)) :O2))
wenn Du diese Formel ziehend herunter kopierst erhältst Du in S6 den richtigen Wert aber in den anderen Zellen nicht, da mE Deine Vorgabe nicht stimmt.
Ich vermute jedoch Du suchst folgende Ergebnisse. Dazu bedarf es auch keiner Hilfsspalte. Formel ziehend nach unten kopieren.

 CGOP
1KN.Nr. Buchung Kosten Je Stück  
22082                4.071,45 €             639,60 € 6,37
32082              34.367,61 €             207,65 € 85,94
42082              19.462,11 €             107,65 € 117,55
52082              23.821,51 €             110,72 € 141,95
620913              17.727,19 €             127,80 € 138,71
720913              18.426,73 €             162,84 € 125,93
820913              26.144,68 €             154,59 € 140,33
920913              14.652,99 €             113,61 € 137,49

Formeln der Tabelle
ZelleFormel
P2{=WENN(C2="";"";MITTELWERT(WENN(C$2:C2=C2;G$2:G2/O$2:O2)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nun bedarf es noch Deiner Definition ...
von: Simon T.
Geschrieben am: 14.10.2015 13:39:08
Hallo, ich habe abermals alles berichtigt.
In der Exceltabelle habe ich Ihnen Kommentare geschrieben. Vielen vielen Dank das sie sich so viel Mühe machen.
https://www.herber.de/bbs/user/100787.xls

Bild

Betrifft: AW: nun ist es eindeutig ... dann SUMMEWENNS() ...
von: ... neopa C
Geschrieben am: 14.10.2015 14:15:35
Hallo Simon,
... dann ohne Hilfsspalte mit folgender Formel in O2:
=WENN(C2="";"";SUMMEWENNS(G$2:G2;C$2:C2;C2)/SUMMEWENNS(N$2:N2;C$2:C2;C2)) und diese Formel nach unten kopieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nun ist es eindeutig ... dann SUMMEWENNS() ...
von: Simon T.
Geschrieben am: 14.10.2015 16:03:35
Super vielen Lieben Dank!
Darf ich dich noch bitte mir kurz anschaulisch zu erklären wie sich die Formel aufbaut? Die Grunddaten sollen sich bald verändern und ich habe die Hoffnung alles anpassen zu können. Leider verstehe ich noch nicht wie die Formel arbeitet. Wenn du möchtest würde ich dir gerne einen kleinen Betrag als Dankeschön zusenden. Du hast mir sehr geholfen und ich will mich dafür bedanken.
LG Simon

Bild

Betrifft: AW: zu SUMMEWENNS() und ... sieh mal ...
von: ... neopa C
Geschrieben am: 14.10.2015 16:42:00
Hallo Simon,
.... hier http://www.online-excel.de/excel/singsel.php?f=188 zusätzlich aber auch hier: http://www.online-excel.de/excel/singsel.php?f=56
Solltest Du dazu noch Fragen haben, kannst Du diese mir auch bei Bedarf auch direket mailen.
Dazu gib bzw. kopiere in eine freie Excelzelle folgende Formel:
=WECHSELN("neopaCode";"Co";ZEICHEN(64)&"email.")
und Du hast dann meine E-Mail-Adresse an die Du Dich wenden kannst. Gib dazu im Betreff folgendes an :mit Bezug auf Herbers Excelforum thread vom 14.10.15
Wenn Du die Mail versendet hast kannst Du dies hier ja kurz mitteilen.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellenfixierung mit WENN Funktion definieren"