Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
684to688
684to688
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Problem mit WENN-Funktion

Problem mit WENN-Funktion
25.10.2005 22:12:45
max
Hallo,
ich finde den Fehler in folgender Funktion nicht:
=WENN([...]A!$B2:$B200=10;(MONATSENDE((KGRÖSSTE([...]A!$D:$D;1);0);)
[...] -&gt entspricht einem Dateinamen
Folgende Logik ist beabsichtigt: Ich möchte aus einer Tabelle einer anderen Datei das neueste Datum selektieren, wenn in Spalte B der Wert 10 vorhanden ist und von dem selektierten Monat den jeweils letzten Tag anzeigen lassen. Am Beispiel:
Tabelle A:
Spalte B2 bis B5: 10;20;10;10;30
Spalte D2 bis D5: 12.02.05;01.01.01;16.01.05;05.08.05;24.09.05
Ergebnis sollte sein: 31.08.05
nach Excel-Hilfe wird bei der WENN-Funktion, wenn eine Matrix als Argument übergeben wurde, jeder Wert überprüft. Leider bekomme ich immer 0 als Wert zurück. Es wäre super, wenn Ihr mir helfen könntet

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Problem mit WENN-Funktion
25.10.2005 23:57:50
Erich
Hallo Max,
deine Formel habe ich erst mit Änderungen formal fehlerlos eingegeben bekommen, sie liefert aber das falsche Ergebnis (in A4).
Du kannst eine der beiden (Matrix-!)Formeln in A1 oder A2 verwenden:
 
 A
131.08.2005
231.08.2005
3 
430.09.2005
Formeln der Tabelle
A1 : {=MONATSENDE(KGRÖSSTE(A!$D2:$D200*(A!$B2:$B200=10);1);0)}
A2 : {=MONATSENDE(KGRÖSSTE(WENN(A!$B2:$B200=10;A!$D2:$D200;0);1);0)}
A4 : =WENN(A!$B2:$B200=10;MONATSENDE(KGRÖSSTE(A!$D2:$D200;1);0);)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige

329 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige