Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
164to168
164to168
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zwischenwert mit Wenn-Funktion

Zwischenwert mit Wenn-Funktion
30.09.2002 12:58:43
Gernot S.
Hallo an Alle!

ich schildere Euch mein Problem anhand eines Beispiels:
Zelle A1 = 10
Zelle A2 = 20
Zelle B1 = beliebige Konstante
Wenn ein errechneter Wert in Zelle A3 zwischen 10 und 20 liegt (also zwischen A1 und A2), dann soll die Konstante in Zelle B1
erscheinen. Wenn der Wert nicht dazwischen liegt, soll die Zelle
frei ("") bleiben.
Wie bekomme ich das mit einer Funktion hin???

Ich wäre Euch sehr dankbar für einen kleinen Tip.
Herzlichen Dank im voraus.

Gernot

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Zwischenwert mit Wenn-Funktion
30.09.2002 13:08:06
Folker

=WENN(UND(C1"<"B1;C1">"A1);5;"")


Die 5 ist die Konstante. Um die grösser kleiner zeichen sind keine "" nur sonst zeigt er sie nicht an.

Re: Zwischenwert mit Wenn-Funktion
30.09.2002 13:15:01
Boris
Hallo Gernot,

in B1 eintragen:

=wenn(und(a3>=10;a3<=20);a3;"")

Sollte es so einfach sein?

Gruß Boris

> sowie <
30.09.2002 13:18:44
WF
Hi Folker,

gib vor und nach dem < bzw. > jeweils ein Leerzeichen ein.
Eine auch mit diesen Leerzeichen kopierte Formel funktioniert; - < > nicht.

Salut WF

http://www.excelformeln.de/
die ultimative Formelseite






Anzeige
Re: Zwischenwert mit Wenn-Funktion
30.09.2002 13:29:57
Ingo
Ich würde es über eine bedingte Formatierung in Zelle B1 lösen.
So kann die Konstante in B1 im Bedarfsfall geändert werden.

Zelle B1 markieren -> Im Menüpunkt "Format" -> Bedingte Formatierung.

Auswählen auf "Formel ist" und dort eingeben =(ODER(A3<=A1;A3>=A2))
und als Format die Schriftfarbe der Hintergrundfarbe der Zelle B1 angleichen.

Gruß
Ingo

Re: Zwischenwert mit Wenn-Funktion
30.09.2002 14:00:42
RolfW
mache dies mit 2 intergrierten Wenn-Funktionen
=WENN(A3grösseralsA1;WENN(A3kleineralsA2;"Konstante";"");"")

grösserals = >
kleinerals = <
kleiner als wird beim beitrag senden leider verworfen, deshalb habe ich es ausgeschrieben

Gruss RolfW











Anzeige
Re: Zwischenwert mit Wenn-Funktion
01.10.2002 23:57:37
Gernot
Hallo Boris,

danke für Deine Hilfe.
Hat geklappt.

Gruß
Gernot

342 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige