Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summe aus Zelle mit Wenn-Funktion

Summe aus Zelle mit Wenn-Funktion
07.11.2013 11:51:12
Marcel
Hallo
Ich habe folgende Probleme in einer Excel-Datei.
Ausgangspunkt:
In der Tabelle1, Zelle B17-B30 ist ein Dropdown mit Bezug auf Tabelle2 B17-B27.
In der Zelle F17-F30,G17-G30,H17-H30 ist eine Wenn-Formel auf Bezung auf das Dropdown in der Zelle B17-B30.
Problem 1:
Nun zeigt es mir in den Zellen F17-F30,G17-G30,H17-H30 keine Dezimalstellen an. Ich habe bereits diverse Zellenformattierungen ausprobiert.
Problem 2:
Nun sollte ich in den Zellen F31,G31,H31 jeweils die SUMME aus der jeweiligen Spalte haben. Auch hier funktioniert es mit Summe nicht.
Hier die Datei:
https://www.herber.de/bbs/user/87976.xls
Kann mir da jemand weiterhelfen?
Besten Dank schon mal im Voraus.

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
besser ist SVERWEIS() ...
07.11.2013 12:07:33
neopa
Hallo Marcel,
... und Dein Formatierungsproblem kann ich nicht nachvollziehen. Formel F17 nach rechts und unten kopieren.
 ABCDEFG
17 A 0,00300,00
18 B 500,000,00
19 LIZ 0,00300,00
20 LIZ2 500,000,00
21     
22     
23     
24     
25     
26     
27     
28     
29     
30     
31Gesamttotal1.000,00600,00

Formeln der Tabelle
ZelleFormel
F17=WENN($B17="";0;SVERWEIS($B17;Tabelle2!$A:$C;SPALTE(B1); ))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Anzeige
ich sehe gerade ...
07.11.2013 12:17:16
neopa
Hallo Marcus,
.. Du hast ja in Spalte H auch noch Werte übernommen. Deshalb schreibe in F17 anstelle
=WENN($B17="";0;SVERWEIS($B17;Tabelle2!$A:$C;SPALTE(B1);)) doch gleich
=WENN($B17="";0;SVERWEIS($B17;Tabelle2!$A:$F;SPALTE(B1);))
und kopiere diese nach rechts und unten.
Gruß Werner
.. , - ...

AW: ich sehe gerade ...
07.11.2013 12:29:25
Marcel
Hallo Werner
Besten Daank für Deine Hilfe.
Wie sagt ein Sprichwort:
Wieso einfach wenn es kompliziert auch geht :-)
Noch ein kleine Frage zur Formatierung.
Ist es möglich, wenn in z.B B20 kein Eintrag ist, das auch keine Nullen zu sehen sind?

Anzeige
mit benutzerdefiniertes Zahlenformat ...
07.11.2013 12:47:10
neopa
Hallo Marcus,
... kannst Du 0-Werte "ausblenden. Und zwar vergib das benutzerdefiniertes Zahlenformat: 0,00;-0,00;
Gruß Werner
.. , - ...

Danke
07.11.2013 13:17:26
Marcel
Nochmals vielen Dank Werner.

329 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige