Microsoft Excel

Herbers Excel/VBA-Archiv

Funktion "Wenn" mit mehreren Argumenten | Herbers Excel-Forum


Betrifft: Funktion "Wenn" mit mehreren Argumenten von: Andreas
Geschrieben am: 19.11.2009 16:00:17

Hallo zusammen,
ich suche die verschachtelte Wennfunktion die mir hilft bei z.B.:

Wenn Zelle A1 = Europa, dann kalkuliere B1*C1
Wenn Zelle A1 = Asien, dann kalkuliere B2*C2 usw. mit mehreren Argumenten.

z.B. =wenn (A1="Europa";B1*C1), wenn(A1="Asien";B2*C2), wenn(A1 = "Afrika";B3*C3)....

Ich kann mich an die Verschachtelung leider nicht mehr erinnern und muss schnell zu einer Lösung kommen.

Schönen Gruß und Danke für eure Hilfe.

Gruß
Andreas

  

Betrifft: AW: Funktion "Wenn" mit mehreren Argumenten von: IngGi
Geschrieben am: 19.11.2009 16:08:12

Hallo Andreas,

=WENN(A1="Europa";B1*C1;WENN(A1="Asien";B2*C2;WENN(A1="Afrika";B3*C3;B4*C4)))

Funktioniert allerdings nur bis zu maximal 8 Argumenten (Excel XP/2003). Reicht dir das?

Gruß Ingolf


  

Betrifft: AW: Funktion "Wenn" mit mehreren Argumenten von: Andreas
Geschrieben am: 19.11.2009 16:19:04

Super, war was ich gesucht hatte Ingolf.
Danke.


  

Betrifft: AW: Funktion "Wenn" mit mehreren Argumenten von: Matthias5
Geschrieben am: 19.11.2009 16:08:50

Hi,

=PRODUKT(INDEX(B1:C3;VERGLEICH(A1;{"Europa"."Asien"."Afrika"};0);))

Gruß,
Matthias


  

Betrifft: @Matthias : Ähnliche Idee wie ich :-) von: NoNet
Geschrieben am: 19.11.2009 16:40:18

Hey Matthias,

häte nicht gedacht,dass jemadn fast die gleiche Idee hätte wie ich.
Habe meinen Beitrag bereits vor über 30 Min. geschrieben, wurde dann von Kollegen "gestört" ;-) und konnte meine Antwort erst jetzt fertigstellen und absenden...

Gruß, NoNet


  

Betrifft: OT: Wir sind ja auch einige Jahre ... von: Matthias5
Geschrieben am: 19.11.2009 16:42:43

Hi NoNet,

...in die gleiche "Schule" gegangen (Spotlight)! ;-)

Gruß,
Matthias


  

Betrifft: Non scholae sed vitae discimus ;-) _oT von: NoNet
Geschrieben am: 19.11.2009 16:52:52

_oT


  

Betrifft: AW: Funktion "Wenn" mit mehreren Argumenten von: jockel
Geschrieben am: 19.11.2009 16:10:43

hi Andreas, kannst du mal (d)eine (beispiel)tabelle hochladen...

cu jörg


  

Betrifft: Lösung ohne WENN und ABER ;-) von: NoNet
Geschrieben am: 19.11.2009 16:37:26

Hallo Andreas,

das kann man ohne WENN() lösen, so dass diese Funktion auch sehr leicht erweiterbar ist :

=PRODUKT(BEREICH.VERSCHIEBEN(B1:C1;VERGLEICH(A1;{"Europa"."Asien"."Afrika"."Amerika"."Australien"};0)-1;0))

Falls neue Regionen (z.B. NAFTA) hinzukommen, dann bitte als neuen Eintrag (an die richtige Stelle !) in die Matrix {"Europa"."Asien"."Afrika"."Amerika"."Australien"} hinzufügen.

Gruß, NoNet


Beiträge aus den Excel-Beispielen zum Thema "Funktion "Wenn" mit mehreren Argumenten"