Summewenn in Verbindung mit Teilergebnis

Bild

Betrifft: Summewenn in Verbindung mit Teilergebnis
von: Hansi
Geschrieben am: 18.11.2003 17:40:33

Hallo,
ich habe eine größere Tabelle in welcher ich mit Autofilter
arbeite. Zum Beispiel kann ich mit Teilergebnis alle Ausgaben
für ein Projekt ermitteln. Jetzt will ich aber in einem separaten
Excel-Sheet mit Summewenn einen weiteren Teilbereich herausfiltern.
Leider bezieht sich dann das "Herausgefilterte" auf die ganze
Liste, auch wenn ich zuvor in der Haupttabelle einen Autofilter
benutzt hatte.
Gibt es da evtl. noch weitere Optionen, die man wählen kann, um
mit Summewenn nur in einem begrenzen Teil "hantieren" zu können?
Vielen Dank für eure Hilfe.
Gruss Hansi

Bild


Betrifft: SUMMEWENN in gefilterter Tabelle
von: Boris
Geschrieben am: 18.11.2003 17:53:36

Hi Hansi,

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:100)))*(B2:B100="Bedingung")*C2:C100)

Spalte A wird überprüft auf gefiltert oder nicht gefiltert - Spalte B enthält deine Bedingung für SUMMEWENN, Spalte C die Werte, die summiert werden sollen.
In Zeile 1 stehen die Spaltenbezeichnungen.

Grüße Boris


Bild

Beiträge aus den Excel-Beispielen zum Thema " Summewenn in Verbindung mit Teilergebnis"