spallten zusammenführung / mit Wenn funktion???

Bild

Betrifft: spallten zusammenführung / mit Wenn funktion???
von: thrilex
Geschrieben am: 04.12.2003 08:25:43

Guten morgen

ich habe ein frage zum thema: funktionen

ich habe eine spallte mit handy nummern z.b 0172,0173,0174 (spallte 1)
und eine spallte mit orts nummern z.B 0211,0221,0234,0423 (Spallte 2)
und dazu habe ich eine spallte neben an so verändert (Spallte 3) das wen in der spallte 1 die 0173 eingebe sagt er mir in spallte 3 das es eine handynummer ist und wen ich in spalte 2 eine nummer habe dann sagt er mir in spallte 3 das ich eine festnetz nummer habe.

so nun will ich die spallten 1 und 2 kombinieren ,zusammenführen . wie mach ich das nun mit der spallte 3 .

Die wenn funktion kann ich nciht nutzen , den bei der masse an auswahlmöglichkeiten mach die wenn funktion schlap(kann max 10 wen funktionen hintereinander machen)

gibt es eine möglichkeit der auswahl so in etwa.
=wenn(spallte 1 = 0172+0173+0174+0175 ;"handy"; sonst "festnetz")

für eure hilfe währe ich sehr dankbar

Bild


Betrifft: so vielleicht ??
von: MRP
Geschrieben am: 04.12.2003 08:41:28

Hallo,
=WENN(Links(A1;2)=01;"Handy;"Festnetz")
Ciao
Manuele Rocco Parrino


Bild


Betrifft: vieleicht etwas erklären
von: thrilex
Geschrieben am: 04.12.2003 08:44:54

hmm kanst du das vieleicht übertragen auf das beispiel mit der spallte 1 und 2 und 3 und denn nummern z.B weil ich verstehe nicht so richtig den bezug von wegen (a1 ;2) u.s.w

=WENN(Links(A1;2)=01;"Handy;"Festnetz")


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: Mac4
Geschrieben am: 04.12.2003 08:51:45

Hi,

das wäre auch eine Möglichkeit:

=WENN(ODER(A1={"0171";"0172";"0173";"0175"});"Handy";"Festnetz")

Marc


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: thrilex
Geschrieben am: 04.12.2003 09:03:23

=WENN(ODER(e48={"692";"693";"694";"695";"696";"160";"161";"162";"163";"164";"165";"166";"167";"168";"169";"170";"171";"172";"173";"174";"175;"176";"177";"178";"179"});"Handy";"Festnetz")

so in etwa wollte ich das gerne machen aber irgent wie will er nicht
kann es sein das die formel zuuu grooss ist ?

mfg thrilex


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: Mac4
Geschrieben am: 04.12.2003 09:15:29

Hi,

da fehlte ein Anführungszeichen!

=WENN(ODER(e48={"692";"693";"694";"695";"696";"160";"161";"162";"163";"164";"165";"166";"167";"168";"169";"170";"171";"172";"173";"174";"175";"176";"177";"178";"179"});"Handy";"Festnetz")

Marc


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: thrilex
Geschrieben am: 04.12.2003 10:34:12

ohh das stimmt aber das problem ist ich bekomme immer nur "festnetz "rus udn nie handy kann es sein das der das oder nciht kennt oder das das ober falsch eingebunden wurde ... ich hab einpaar sachen versucht aber klappte nicht wirklich

hier nochmal die formel

=WENN(ODER(D11={"692";"693";"694";"695";"696";"150";"151";"152";"159";"160";"161";"162";"163";"164";"165";"166";"167";"168";"169";"170";"171";"172";"173";"174";"175";"176";"177";"178";"179"});"Handy";"Festnetz")


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: Mac4
Geschrieben am: 04.12.2003 10:46:24

Hi,

kannst Du nicht mal ein Beispiel hochladen - macht es einfacher!

Marc


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: thrilex
Geschrieben am: 04.12.2003 10:55:47

https://www.herber.de/bbs/user/2301.xls

das ist die datei ich hoffe du hast den durchblick denn ich bin mir nicht sicher wie ich das sonst machen soll

mfg thrilex


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: Mac4
Geschrieben am: 04.12.2003 11:08:00

Hi,

das war ein Formatproblem. Ich bin in meinem Beispiel davon ausgegangen, dass die Spalte mit den Vorwahlen Text sind (wegen der führenden Null). Da bei Dir diese Spalte aber echte Zahlen sind, musst Du in der Formel alle Anführungszeichen entfernen - dann klappts!

Marc


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: thrilex
Geschrieben am: 04.12.2003 12:30:55

super es geht danke dir für deine hilfe


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: thrilex
Geschrieben am: 04.12.2003 09:03:30

=WENN(ODER(e48={"692";"693";"694";"695";"696";"160";"161";"162";"163";"164";"165";"166";"167";"168";"169";"170";"171";"172";"173";"174";"175;"176";"177";"178";"179"});"Handy";"Festnetz")

so in etwa wollte ich das gerne machen aber irgent wie will er nicht
kann es sein das die formel zuuu grooss ist ?

mfg thrilex


Bild


Betrifft: AW: spallten zusammenführung / mit Wenn funktion???
von: Markus H.
Geschrieben am: 04.12.2003 09:51:37

Lad mal die Datei hoch..


Bild

Beiträge aus den Excel-Beispielen zum Thema " spallten zusammenführung / mit Wenn funktion???"