Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN auf Anzahl (x-letzten) beschränken

Betrifft: SUMMEWENN auf Anzahl (x-letzten) beschränken von: max
Geschrieben am: 14.11.2014 18:38:17

Hallo, ich komme irgendwie nicht weiter.
Ich möchte die Summe der letzten x-Verkäufe, welche vor dem aktuellem Datum liegen erhalten. Im File habe ich ein Beispiel. SummeWenn funktioniert, allerdings eben die Summe über alle bisherigen Verkäufe. Das Ziel ist beispielhaft in Spalte F dargestellt.
Aktueller Tag 30.01.2007. D.h. die letzten Verkäufe (vor 30.1.2007) sollen addiert werden. (farbig markiert) Wie kann ich dies noch intergrieren?
Vielen Dank
max

https://www.herber.de/bbs/user/93777.xlsx

  

Betrifft: AW: SUMMEWENN auf Anzahl (x-letzten) beschränken von: max
Geschrieben am: 14.11.2014 18:47:07

Ergänzung: das x von "letzten x-Verkäufe" soll aus Zelle B2 übernommen werden.


  

Betrifft: mit SUMME(INDEX():INDEX())... von: neopa C (paneo)
Geschrieben am: 14.11.2014 19:46:23

Hallo Max,

... ich hab das Suchdatum mal in A1 geschrieben. Dann:

=WENNFEHLER(SUMME(INDEX(C:C;VERGLEICH(A1;B:B;)-MIN(10;VERGLEICH(A1;B:B;)-5)):INDEX(C:C;VERGLEICH(A1;B:B;)-1));"Datum muss in Spalte B vorhanden sein")

wenn es das Datum nicht gibt, wird es etwas komplizierter.

Gruß Werner
.. , - ...


  

Betrifft: AW: mit SUMME(INDEX():INDEX())... von: max
Geschrieben am: 14.11.2014 21:02:50

Hallo Werner,
vielen Dank, dein Vorschlag kommt dem Ziel schon näher.
Aber du hast ja auch schon bemerkt, dass das Datum in B vorhanden sein muss.
Ziel sollte sein, dass in jeder Zeile eine Summe der letzten x-Verkäufe, welche vor dem Datum in Spalte A realisiert wurden, erscheint. Außerdem soll dieses x variierbar (Zelle B2) sein.
Grüße Max


  

Betrifft: im einfachsten Fall muss Du doch nur .... von: neopa C (paneo)
Geschrieben am: 15.11.2014 14:18:37

Hallo Max,

... in meiner bisherigen Formel die 10 durch B2 ersetzen.

Deine Präzisierung Deiner Aufgabenstellung wird dies aber noch nicht gerecht. Dafür ist dann wie angekündigt eine Matrixformel sinnvoll.

Folgende Formel nach unten kopieren (evtl. muss bei anderen Daten der "Spreizwert" 99 noch erhöht bzw. kann auch niedriger gesetzt werden)

 F
60

Formeln der Tabelle
ZelleFormel
F6{=SUMME(INDEX(C:C;MAX(KGRÖSSTE((B$5:B99<A6)*ISTZAHL(C$5:C99)*ZEILE(A$5:A99); B$2); 5)):INDEX(C:C;MAX(5;(B$5:B99<A6)*ISTZAHL(C$5:C99)*ZEILE(A$5:A99))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: im einfachsten Fall muss Du doch nur .... von: max
Geschrieben am: 15.11.2014 15:00:16

Hallo Werner,
Danke für den Vorschlag - den ich im Moment noch nicht ganz verstehe - ich brauche da etwas mehr zeit.
Leider gibt gibt es bei mir einen Fehler: in der Spalte F steht nun "#ZAHL!"
Ich habe das file nochmal hochgeladen.
Grüße Max

https://www.herber.de/bbs/user/93791.xlsx


  

Betrifft: Problem gelöst von: max
Geschrieben am: 15.11.2014 15:08:14

ich hatte nicht mit STRG+SHIFT+RETURN abgeschlossen.
Danke


 

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN auf Anzahl (x-letzten) beschränken"