SUMMEWENNS mit dyn. Auswahl+Anzahl Kriterien

Bild

Betrifft: SUMMEWENNS mit dyn. Auswahl+Anzahl Kriterien
von: Mark
Geschrieben am: 17.11.2015 17:30:05

(Beispiel: https://www.herber.de/bbs/user/101594.xlsx )
Hallo zusammen,
Ich habe eine Rohdatentabelle, in der Werte (eine Wert-Spalte) nach einer Handvoll Dimensionen sortiert sind, im Beispiel Dimension1, ..2 und ..3
Kombinationen von Dimensionen sind keine Unikate.
Nun benötige ich eine Lookup-Tabelle, in der sowohl a) die Dimension selbst, als auch b) der Wert der Dimension dynamisch angegeben werden, um die Summe der entsprechenden Werte aus der Rohdatentabelle zu ziehen.
Mein Ansatz in Gedanken war, die Dimensionsspalten in meiner Rohdatentabelle einfach zu benannten Bereichen zu machen und dann per INDIREKT() die Angabe der relevanten Dimension in einen Bezug umzuwandeln - funktioniert aber natürlich nicht, da INDIREKT() auf einen leeren Wert einen Bezugsfehler zurückgibt.
Hat irgendjemand eine Idee, was ich hier tun kann?
Danke,
Mark.

Bild

Betrifft: AW: SUMMEWENNS mit dyn. Auswahl+Anzahl Kriterien
von: Daniel
Geschrieben am: 17.11.2015 17:57:21
Hi
ganz dynamisch ist es nicht, weil du diese Formel für die maximale Anzahl von Bedingungen auslegen musst, aber mal als Ansatz:
=SUMMEWENNS($F$1:$F$17;INDEX($B$1:$F$17;0;WENN(J2="";1;VERGLEICH(J2;$B$1:$D$1;0)));WENN(J2="";"*";K2) ;INDEX($B$1:$F$17;0;WENN(L2="";1;VERGLEICH(L2;$B$1:$D$1;0)));WENN(L2="";"*";M2);INDEX($B$1:$F$17;0; WENN(N2="";1;VERGLEICH(N2;$B$1:$D$1;0)));WENN(N2="";"*";O2))
funktioniert so auch nur mit Texten als Suchkriterium und nicht mit Zahlen.
das Prinzip ist, dass wenn du eine LookUp-Spalte leer lässt, an dieser Stelle eine beliebige Suchspalte eingesetzt wird (hier die erste) und als Suchbegriff der Joker *
anderen Falls wird die passende Spalte über Index und Vergleich gewählt.
Gruß Daniel

Bild

Betrifft: AW: mit MATRIXformel auch Zahlensuchkrit. mögl...
von: ... neopa C
Geschrieben am: 17.11.2015 19:14:43
Hallo Mark,
... wobei bei nachfolgender Formel auch nur die momentan drei Bedingungen in der Formel berücksichtigt sind. Allerdings Zahlenwerte als Suchkriterium wären hier möglich (Formel nach unten kopieren):

 BCDEFGHIJKLMNOP
1Dimension1Dimension2Dimension3(….)Wert   Lookup1 Value1Lookup2Value2Lookup3Value3Summe
2101001 1   Dimension201    13107
3101002 2   Dimension12Dimension3002  41120
4102001 4   Dimension3001Dimension11Dimension2021028
5102002 8          
6201001 16          
7201002 32          
8202001 64          
9202002 128          
10101001 256          
11101002 512          
12102001 1024          
13102002 2048          
14201001 4096          
15201002 8192          
16202001 16384          
17202002 32768          
18               
19               

Formeln der Tabelle
ZelleFormel
P2{=SUMME(WENN(J2="";1;(INDEX(A$2:E$20;;VERGLEICH(J2;$1:$1;))=K2))*WENN(L2="";1;(INDEX(A$2:E$20;;VERGLEICH(L2;$1:$1;))=M2))*WENN(N2="";1;(INDEX(A$2:E$20;;VERGLEICH(N2;$1:$1;))=O2))*F$2:F$20)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit MATRIXformel auch Zahlensuchkrit. mögl...
von: Mark
Geschrieben am: 18.11.2015 09:15:03
Vielen Dank Euch beiden für die Lösungen! Ich fang dann mal an zu basteln... ;)
VG
Mark.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENNS mit dyn. Auswahl+Anzahl Kriterien"