Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenns | Herbers Excel-Forum


Betrifft: Summewenns von: cfrei75
Geschrieben am: 21.10.2008 10:57:16

Hallo ich habe folgende Formel: =SUMMEWENNS(C4:CT4;C3:CT3;">6:00";C3:CT3;"<=21:00")

Diese funktioniert einwandfrei, möchte aber anstatt die 6:00 und 21:00 händisch reinzuschreiben, dass diese von einem Feld übernommen wird, da diese variabel sind.

Wenn ich aber die Formel wie folgt schreibe =SUMMEWENNS(C4:CT4;C3:CT3;">a1";C3:CT3;"<=b1") dann funktioniert es nicht. Auch nicht wenn ich die " weglasse.

Könnte mir bitte jemand helfen. Vielen Dank!!!

Viele Grüsse
Claus

  

Betrifft: AW: Summewenns von: JogyB
Geschrieben am: 21.10.2008 11:08:26

">a1" durch A1 und "<=b1" durch B1 ersetzen, in die Zelle kommt dann Uhrezeit mit Vergleichsoperator, also >6:00 in A1 und <=21:00 in B1.

Und das "Excel gut" würde ich an Deiner Stelle mal dringend überdenken.

Gruss, Jogy


  

Betrifft: AW: Summewenns von: David
Geschrieben am: 21.10.2008 11:32:21

Hallo Jogy,

nur so als Zuschauer:

Wenn in der Zelle aber nur die Uhrzeit stehen darf (vielleicht wird damit ja noch woanders gerechnet), was machst du dann?

Gruß
David


  

Betrifft: AW: Summewenns von: JogyB
Geschrieben am: 21.10.2008 15:20:18

Hi.

Vielleicht dasselbe, was Du auch gemacht hast? Oder in eine Zelle den Operator und in die andere Zelle die Uhrzeit.

Gruss, Jogy


  

Betrifft: AW: Summewenns von: David
Geschrieben am: 21.10.2008 11:36:45

Hallo Claus,

ich habe jetzt hier kein Office 2007 zum Testen, aber in 2003 funzt das mit SUMMEWENN so:

=SUMMEWENN(C4:H4;">"&C1;C3:H3)



das hieße auf dein Beispiel angewandt:

=SUMMEWENNS(C4:CT4;C3:CT3;">"&a1;C3:CT3;"<="&b1)



probier's mal aus.

Gruß
David