Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw.

Betrifft: SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw. von: Peter
Geschrieben am: 24.11.2014 10:55:02

Guten Tag

Ich möchte die Formel
=WENN($O29070="x";SUMMEWENNS(_DETAIL_H;_DETAIL_MC;$A29070;_DETAIL_KW_ISO;$N29070);"")
mit einem weiteren Argument erweitern.
Und zwar sollen Werte im mit "_DETAIL_H" benannten Bereich nur addiert werden, wenn
im mit "_DETAIL_LE" benannten Spaltenbereich nicht ein Kürzel steht, der mit dem Buchstaben "Z" beginnt.

Ich habe versucht, zwei zusätzliche Argumente der Funktion SUMMEWENNS mitzugeben, nämlich
Links(_DETAIL_LE;1) und
"<>"&"Z"

womit die Formel so aussehen würde:
=WENN($O29070="x";SUMMEWENNS(_DETAIL_H;_DETAIL_MC;$A29070;_DETAIL_KW_ISO;$N29070;LINKS(_DETAIL_LE;1); "<>"&"Z");"")

Doch das funktioniert nicht. Was ist falsch?

Gruss, Peter

  

Betrifft: AW: SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw. von: SF
Geschrieben am: 24.11.2014 10:56:48

Hola,

nimm Summenprodukt(). Da funktioniert die Variante mit LINKS().

Gruß,
steve1da


  

Betrifft: AW: SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw. von: Rudi Maintaire
Geschrieben am: 24.11.2014 10:59:53

Hallo,
....; Detail_le;"<>z*")

Gruß
Rudi


  

Betrifft: AW: SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw. von: Peter
Geschrieben am: 24.11.2014 11:38:18

Hallo Rudi

Weiss nicht, ob ich etwas falsch gemacht habe.

Bei der Auswertung mit SUMMEWENNS hat es mir die Zeile nicht ausgeschlossen, bei der im Bereich "_DETAIL_LE" ein String, der mit "Z" beginnt, eingetragen ist.

Vgl. Hochgeladene Datei als Beispiel.

Gruss, Peter

https://www.herber.de/bbs/user/93978.xlsm


  

Betrifft: AW: SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw. von: SF
Geschrieben am: 24.11.2014 12:09:28

Hola,

nimm mal in der Formel das Leerzeichen vor Z weg ;)

Gruß,
steve1da


  

Betrifft: AW: SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw. von: Peter
Geschrieben am: 24.11.2014 12:14:52

Hallo
Danke - muss man schon sehen :-)

Gruss, Peter


  

Betrifft: AW: SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw. von: Peter
Geschrieben am: 24.11.2014 11:04:04

Hallo zusammen
Vielen Dank für die beiden funktionierenden Lösungen!
Um nicht mit irgendwelchen Texteinträgen zu kollidieren, nehme ich gerne die Variante mit SUMMEWENNS

Gruss, Peter


 

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENNS - bestimmte Spalte nur 1. Buchst. ausw."