Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Leere Zellen ignorieren
Stef
Hallo zusammen
ich habe unter dem Tabellenblatt Namens "Personal!"
eine Personalliste welche Pro Zeile eine Person und deren Eigenschaften steht
Nun Filtere ich mit der unten stehenden Formel gewisse Personen in "Tabelle1"
Tabelle1
A33=WENN(Personal!L3>0;Personal!C3;0)~f~
bis
~f~A233=WENN(Personal!L203>0;Personal!C203;0)
da nun manche Zeilen leer bleiben hätte ich gerne das die leerzeilen nicht entstehen.
dh. wenn auch nur das kriterium aus Personal!C203 zuträfe dieses in
Tabelle1 A33 geschrieben wird, ansonsten halt alle zuteffenden untereinander

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Leere Zellen ignorieren
10.10.2011 15:37:42
Stef
Danke für die Antwort jedoch
Erste Zeile A33 funktioniert mit
=WENN(ZEILEN(Personal!$3:3)>ZÄHLENWENN(Personal!L:L;"x");"";INDEX(Personal!C:C; KKLEINSTE(WENN(Personal!L$1:L$423="x";ZEILE($1:$99));ZEILE(A1)))) ~f~
in A34 steht nun durchs herapkopieren
~f~
f~=WENN(ZEILEN(Personal!$3:4)>ZÄHLENWENN(Personal!L:L;"x");"";INDEX(Personal!C:C;KKLEINSTE(WENN(Personal!L$1:L$423="x";ZEILE($1:$423));ZEILE(A2))))
und es kommt die Fehlermeldung
#ZAHL!
ich möchte doch Namen und keine Ziffern :-)
LG
Anzeige
AW: Leere Zellen ignorieren
10.10.2011 16:20:31
silex1
Hallo,
na wohl dies überlesen:
ACHTUNG! Ist ne Matrixformel. Nach der Letzten ), STRG+Shifttaste festhalten und Enter drücken. Somit werden die {} erzeugt!
Wenn es nicht funktioniert, poste mal bitte ne Bsp.-Datei.
VG René
AW: Leere Zellen ignorieren
10.10.2011 17:58:55
silex1
Hallo,
Arbeitsblatt mit dem Namen 'Entenhausen'
 A
37Bustermann, B

ZelleFormel
A37{=WENN(ZEILEN(Personal!$3:3)#ZÄHLENWENN(Personal!L:L;"x");"";INDEX(Personal!C:C; KKLEINSTE(WENN(Personal!L$1:L$423="x";ZEILE($1:$423));ZEILE(A1))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.

Die # noch durch ein größer als abändern! Und nach unten kopieren!
Originaldatei
https://www.herber.de/bbs/user/76940.xls
Was sind Matrixformeln?
http://www.online-excel.de/excel/singsel.php?f=26
VG René
Anzeige
Danke
10.10.2011 18:49:50
Stef
Wow
War ne schwere geburt bis man den ablauf erst mal drin hat.
Habe noch nie mit Matrixformeln gearbeitet.
Vielen Dank Nochmals

366 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige