Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zellen mit leerem Formelergebnis zählen

Zellen mit leerem Formelergebnis zählen
23.03.2022 07:35:31
Heinz
Guten Morgen Liebe Excelenten,
ich habe eine (scheinbar) einfache Herausforderung.
Ich lasse in einer Ergebnis-Spalte mit verketten die Inhalte aus anderen Spalten zusammenfassen.
Manchmal befindet sich Text in den Zellen der Ergebnisspalte - wenn in den verketteten Zellen Inhalte waren -
und manchmal ist die Zelle scheinbar leer.
Aber es ist logischerweise immer die Verketten-Formel in der Eingabezelle zu sehen.
Bis hierher ist alles i.O.
Wie kann ich jetzt zählen lassen, in wie vielen Zellen der Ergebnisspalte sich ein Inhalt befindet und in wie vielen Fällen
die Verkettung zu keinen Inhalten geführt hat?
Ungleich 0 oder so ähnlich funkt nicht, weil ja immer die Formel in der Zelle enthalten ist.
Mit einer Hilfsspalte würde ich das hinkriegen, aber kann ich das
auch direkt auswerten?
Ich freue mich auf Eure Vorschläge
Heinz

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zellen mit leerem Formelergebnis zählen
23.03.2022 07:38:59
MCO
Hallo Heinz!
Kannst du das am Ergebnistyp festmachen oder an der Länge des Ergebnisses? ISTTEXT, ISTFEHL(ER), oder LÄNGE()<15 oder sowas?
Gruß, MCO
AW: Zellen mit leerem Formelergebnis zählen
23.03.2022 09:12:26
UweD
Hallo
hier mal Beispiele:
Userbild

=SUMMENPRODUKT((ISTFORMEL($A$1:$A$15))*($A$1:$A$15=""))
=SUMMENPRODUKT((ISTFORMEL($A$1:$A$15))*($A$1:$A$15""))
=ANZAHL(A1:A15)
LG UweD
AW: Zellen mit leerem Formelergebnis zählen
23.03.2022 09:13:52
Michael
Moin,
wenn Spalte A die wäre, die Du prüfen möchtest, dann

=SUMMENPRODUKT(--(A:A""))
VG Michael
Anzeige
AW: Zellen mit leerem Formelergebnis zählen
23.03.2022 09:22:21
Daniel
Hi
Zellen mit mindesten einem Zeichen Inhalt zählst du mit ZählenWenn(A:A;"?*")
Die Gesamtzahl der Formeln bekommst du mit Anzahl2(A:A)
Die leeren Zellen sind dann die Differenz.
Gruß Daniel
AW: Zellen mit leerem Formelergebnis zählen
23.03.2022 10:09:07
Heinz
Hallo an Alle,
viele Dank für Eure Lösungen.
Ich hab jetzt mal die Variante von genommen, weil ich die verstehe und Summenprodukt gerne nutze.
Bei der Lösung von Michael fehlt mir der "intellektuelle Zugang" :-)
Die Lösung von Daniel ist pragmatisch und funkt natürlich auch.
Ich wünsche Eich noch einen schönen Tag.
Heinz

338 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige