Microsoft Excel

Herbers Excel/VBA-Archiv

Formel die mit mehreren Zellen rechnet | Herbers Excel-Forum


Betrifft: Formel die mit mehreren Zellen rechnet von: uwe
Geschrieben am: 21.02.2012 14:30:50

Hallo!
Ich habe mehrere Formeln die mit mehreren Zellen rechnen. Jedoch zeigt mir Excel immer #Wert an und ich habe herausgefunden das mehreren Zellen(Rot markiert), in der eine simple Wenn-Funktion steht nicht berücksichtigt wird. Erst wenn ich die Formel durch eine harte Zahl überschreibe rechnet Excel mit dieser.

Habe sämtliche Formatierungen usw. ausprobiert, kann aber leider keinen Fehler finden.

Kann mir bitte jemand Helfen
Datei im Anhang

https://www.herber.de/bbs/user/79020.xlsx

  

Betrifft: AW: Formel die mit mehreren Zellen rechnet von: Rudi Maintaire
Geschrieben am: 21.02.2012 15:03:40

Hallo,
der Fehler ist, dass du "" in die Zellen schreibst anstatt 0.

Gruß
Rudi


  

Betrifft: AW: Formel die mit mehreren Zellen rechnet von: uwe
Geschrieben am: 21.02.2012 15:49:54

Hallo,
Danke erst mal für die schnelle Antwort
aber in der FormelD24 fun.es nicht wenn ich in A12 einen Wert eingebe Rechnet D2 richtig in D24 kommt Fehler #wert und wenn in a21 kein wert eingegeben wird kommt in u21 auch die Fehlermeldung #wert ich bin Ratlos???


  

Betrifft: =Wenn(....;0) anstatt =Wenn(....;"") owT von: Rudi Maintaire
Geschrieben am: 21.02.2012 16:09:29




  

Betrifft: AW: Formel die mit mehreren Zellen rechnet von: uwe
Geschrieben am: 21.02.2012 20:34:21

Hallo
ich habe die Formel (=WENN(UND($A$21<>0;$D$21<>0);$A$21*$D$21*$Q$21;0)) so eingegeben es kommt immer Fehler #WERT
was mache ich Falsch


  

Betrifft: AW: Formel die mit mehreren Zellen rechnet von: uwe
Geschrieben am: 21.02.2012 22:24:40

noch mal Danke für die Hilfe
habe den Wald vor lauter Bäume nicht gesehen


Beiträge aus den Excel-Beispielen zum Thema "Formel die mit mehreren Zellen rechnet"