Microsoft Excel

Herbers Excel/VBA-Archiv

Formellösung für Zeitraumauswertung gesucht | Herbers Excel-Forum


Betrifft: Formellösung für Zeitraumauswertung gesucht von: WalterK
Geschrieben am: 11.02.2012 21:56:35

Hallo,

ich suche eine Formellösung für die in der hochgeladenen Datei im Bereich M3:X7 eingetragenen Zahlen.

In Spalte J ist das jeweilige Jahr eingetragen, im Bereich M2:X2 sind die Monate Jänner bis Dezember.

Gesucht wird eine Formel, die in den jeweiligen Monaten und Jahren die Anzahl der im Zeitraum(C:D) liegenden Kalendertage angibt.

Hier noch die Datei:
https://www.herber.de/bbs/user/78866.xls

Besten Dank für Eure Hilfe, Servus Walter

  

Betrifft: AW: Formellösung für Zeitraumauswertung gesucht von: Josef Ehrensberger
Geschrieben am: 11.02.2012 22:04:44


Hallo Walter,

Null-Werte per Format ausblenden!

Tabelle1

 ABCDEFGHIJKLMNOPQRSTUVWXY
1                         
2 NameVonBis     Jahr  JännerFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezember 
3 Fam115.05.200918.10.2009     2009      173031313018   
4 Fam201.01.200016.05.2011     2008  312931303130313130313031 
5 Fam318.11.200602.02.2007     2006            1331 
6 Fam 1218.02.200717.10.2010     2007   1131303130313130313031 
7 Fam520.10.200101.03.2010     2010  31281          

Formeln der Tabelle
ZelleFormel
M3=SUMMENPRODUKT((JAHR(ZEILE(INDIREKT($C3&":"&$D3)))=$J3)*(MONAT(ZEILE(INDIREKT($C3&":"&$D3)))=SPALTE(A$1)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: Sepp, einfach klasse! Danke und Servus, Walter von: WalterK
Geschrieben am: 11.02.2012 22:11:00




  

Betrifft: besser ohne INDIREKT() von: Josef Ehrensberger
Geschrieben am: 11.02.2012 22:13:32

Tabelle1

 ABCDEFGHIJKLMNOPQRSTUVWXY
1                         
2 NameVonBis     Jahr  JännerFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezember 
3 Fam115.05.200918.10.2009     2009      173031313018   
4 Fam201.01.200016.05.2011     2008  312931303130313130313031 
5 Fam318.11.200602.02.2007     2006            1331 
6 Fam 1218.02.200717.10.2010     2007   1131303130313130313031 
7 Fam520.10.200101.03.2010     2010  31281          

Formeln der Tabelle
ZelleFormel
M3=SUMMENPRODUKT((JAHR(ZEILE(INDEX($A:$A;$C3):INDEX($A:$A;$D3)))=$J3)*(MONAT(ZEILE(INDEX($A:$A;$C3):INDEX($A:$A;$D3)))=SPALTE(A$1)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



« Gruß Sepp »



  

Betrifft: Formel ohne INDIREKT und ohne SUMMENPRODUKT von: Erich G.
Geschrieben am: 12.02.2012 06:37:06

Hi Walter,
das sollte auch ausreichen:

 BCDJKLMNWX
2NameVonBisJahr  JännerFebruarNovemberDezember
3Fam115.05.200918.10.20092009  0000
4Fam201.01.200016.05.20112008  31293031
5Fam318.11.200602.02.20072006  001331
6Fam 1218.02.200717.10.20102007  0113031
7Fam520.10.200101.03.20102010  312800

Formeln der Tabelle
ZelleFormel
M3=MAX(;MIN($D3+1;DATUM($J3;SPALTE(B3); 1))-MAX($C3;SPALTE(A3)&-$J3))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: noch eine Variante von: Erich G.
Geschrieben am: 12.02.2012 06:45:25

Hi,
oder so:

 M
2Jänner
30

Formeln der Tabelle
ZelleFormel
M3=MAX(;MIN($D3;DATUM($J3;SPALTE(B3); ))+1-MAX($C3;SPALTE(A3)&-$J3))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: noch eine Variante von: WalterK
Geschrieben am: 12.02.2012 15:03:56

Hallo,

Danke an die Formelkünstler Sepp und Erich, habe alle Varianten für mich archiviert.

Servus, Walter