Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Formellösung für Zeitraumauswertung gesucht

Formellösung für Zeitraumauswertung gesucht
WalterK
Hallo,
ich suche eine Formellösung für die in der hochgeladenen Datei im Bereich M3:X7 eingetragenen Zahlen.
In Spalte J ist das jeweilige Jahr eingetragen, im Bereich M2:X2 sind die Monate Jänner bis Dezember.
Gesucht wird eine Formel, die in den jeweiligen Monaten und Jahren die Anzahl der im Zeitraum(C:D) liegenden Kalendertage angibt.
Hier noch die Datei:
https://www.herber.de/bbs/user/78866.xls
Besten Dank für Eure Hilfe, Servus Walter

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Formellösung für Zeitraumauswertung gesucht
11.02.2012 22:04:44
Josef

Hallo Walter,
Null-Werte per Format ausblenden!
Tabelle1

 ABCDEFGHIJKLMNOPQRSTUVWXY
1                         
2 NameVonBis     Jahr  JännerFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezember 
3 Fam115.05.200918.10.2009     2009      173031313018   
4 Fam201.01.200016.05.2011     2008  312931303130313130313031 
5 Fam318.11.200602.02.2007     2006            1331 
6 Fam 1218.02.200717.10.2010     2007   1131303130313130313031 
7 Fam520.10.200101.03.2010     2010  31281          

Formeln der Tabelle
ZelleFormel
M3=SUMMENPRODUKT((JAHR(ZEILE(INDIREKT($C3&":"&$D3)))=$J3)*(MONAT(ZEILE(INDIREKT($C3&":"&$D3)))=SPALTE(A$1)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »

Anzeige
Sepp, einfach klasse! Danke und Servus, Walter
11.02.2012 22:11:00
WalterK
besser ohne INDIREKT()
11.02.2012 22:13:32
Josef
Tabelle1

 ABCDEFGHIJKLMNOPQRSTUVWXY
1                         
2 NameVonBis     Jahr  JännerFebruarMärzAprilMaiJuniJuliAugustSeptemberOktoberNovemberDezember 
3 Fam115.05.200918.10.2009     2009      173031313018   
4 Fam201.01.200016.05.2011     2008  312931303130313130313031 
5 Fam318.11.200602.02.2007     2006            1331 
6 Fam 1218.02.200717.10.2010     2007   1131303130313130313031 
7 Fam520.10.200101.03.2010     2010  31281          

Formeln der Tabelle
ZelleFormel
M3=SUMMENPRODUKT((JAHR(ZEILE(INDEX($A:$A;$C3):INDEX($A:$A;$D3)))=$J3)*(MONAT(ZEILE(INDEX($A:$A;$C3):INDEX($A:$A;$D3)))=SPALTE(A$1)))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
« Gruß Sepp »

Anzeige
Formel ohne INDIREKT und ohne SUMMENPRODUKT
12.02.2012 06:37:06
Erich
Hi Walter,
das sollte auch ausreichen:
 BCDJKLMNWX
2NameVonBisJahr  JännerFebruarNovemberDezember
3Fam115.05.200918.10.20092009  0000
4Fam201.01.200016.05.20112008  31293031
5Fam318.11.200602.02.20072006  001331
6Fam 1218.02.200717.10.20102007  0113031
7Fam520.10.200101.03.20102010  312800

Formeln der Tabelle
ZelleFormel
M3=MAX(;MIN($D3+1;DATUM($J3;SPALTE(B3); 1))-MAX($C3;SPALTE(A3)&-$J3))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige
noch eine Variante
12.02.2012 06:45:25
Erich
Hi,
oder so:
 M
2Jänner
30

Formeln der Tabelle
ZelleFormel
M3=MAX(;MIN($D3;DATUM($J3;SPALTE(B3); ))+1-MAX($C3;SPALTE(A3)&-$J3))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige
AW: noch eine Variante
12.02.2012 15:03:56
WalterK
Hallo,
Danke an die Formelkünstler Sepp und Erich, habe alle Varianten für mich archiviert.
Servus, Walter

306 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige