Microsoft Excel

Herbers Excel/VBA-Archiv

Zelle zuordnen und Wert übernehmen | Herbers Excel-Forum


Betrifft: Zelle zuordnen und Wert übernehmen von: beta
Geschrieben am: 10.12.2009 13:06:07

Hallo Forum

Ich habe eine Tabelle mit zwei Spalten angelegt:

Spalte “A” = Kundennummer
Spalte “B” = Kundenname

In Zeile 1 habe ich manuell eine Kundennummer angelegt.
Für jede eingehende Bestellung soll ein neuer Datensatz angelegt werden.
Die Zellen in Spalte “A” sollen dabei Folgendes können:
In Spalte “B” wird der Kundenname eingetragen. Wenn sich dieser in der Spalte “B” noch nicht wiederfindet wird in Spalte “A” eine neue Kundennummer vergeben (grösster Wert aus Spalte “A”+1).
Geht jedoch eine Bestellung eines Kunden ein, der bereits vorher schon einmal bestellt hat, soll in Spalte “A” die zugehörige Kundennummer automatisch übernommen werden.
Wie geht das?
Ich habe bereits gestern ein posting zu dieser Fragestellung aufgegeben und nach einer Hilfestellung auch eine scheinbare Lösung gefunden. Jedoch hat hierbei (eine Matrixauswertung) die Zuordnung des Wertes aus Spalte “A” bei einem bereits eingetragenen Kunden nur für die erste Zeile der Tabelle funktioniert. Irgendwie stehe ich auf dem Schlauch.
Darum bin ich sehr dankbar für weitere Hilfestellungen.

Schöne Grüsse

beta

  

Betrifft: AW: Zelle zuordnen und Wert übernehmen von: {Boris}
Geschrieben am: 10.12.2009 13:18:43

Hi,

A2 (und runterkopieren):

=WENN(B2="";"";WENN(ZÄHLENWENN(B$2:B2;B2)=1;MAX(A$1:A1)+1;INDEX(A:A;VERGLEICH(B2;B:B;))))

Grüße Boris


  

Betrifft: AW: Zelle zuordnen und Wert übernehmen von: beta
Geschrieben am: 10.12.2009 13:39:55

Hallo Boris

das war auf den Punkt genau das was ich gebraucht habe.

Besten Dank
und schöne Grüsse

beta


Beiträge aus den Excel-Beispielen zum Thema "Zelle zuordnen und Wert übernehmen"