Microsoft Excel

Herbers Excel/VBA-Archiv

Mit Matrixformeln berechnete Werte übernehmen | Herbers Excel-Forum


Betrifft: Mit Matrixformeln berechnete Werte übernehmen von: Karin
Geschrieben am: 21.12.2009 11:24:28

Hallo Excelgemeinde,

ich habe eine Lagerdatei mit circa 50 Tabellenblättern. Auf das erste Tabellenblatt sollen in Spalte H immer die letzten Werte der anderen Tabellenblätter aus Spalte J übernommen werden. Die Werte in den einzelnen Tabellenblättern ermittle ich mit Matrixformeln. Meine Versuche, die Werte mit "Index..." oder "Verweis" zu übernehmen, scheitern wegen der Matrixformeln (?). Hat mir jemand einen anderen Vorschlag zur Übernahme der Daten? Formel... Makro... Eine Musterdatei lade ich hoch. Für Unterstützung bin ich sehr, sehr dankbar!
Karin

https://www.herber.de/bbs/user/66734.xls

  

Betrifft: AW: Mit Matrixformeln berechnete Werte übernehmen von: Daniel
Geschrieben am: 21.12.2009 11:51:41

Hi

ändere die Formel in deinen Einzelblättern Spalte J so ab:

{=WENN(E3:I3="";FALSCH;SUMME(J2+E3-G3-H3-I3))}
dann kannst du im Zusammenfassungsblatt mit der Verweis-Funktion nach FALSCH suchen lassen um so die letzte Zeile zu finden.
=INDEX('Le Pavot Rosé 2004'!J:J;VERGLEICH(FALSCH;'Le Pavot Rosé 2004'!J:J;0)-1)
Gruß, Daniel


  

Betrifft: AW: Mit Matrixformeln berechnete Werte übernehmen von: Karin
Geschrieben am: 21.12.2009 13:14:14

Hallo Daniel,

danke für deine schnelle Hilfe. Deine Formeln funktionieren. Ich habe allerdings die Befürchtung, dass der Mitarbeiter, der sie Tabellenblätter ausfüllen muss, durch die Meldung FALSCH irritiert wird.

Trotzdem, vielen Dank!
Karin


  

Betrifft: AW: Mit Matrixformeln berechnete Werte übernehmen von: Christian
Geschrieben am: 21.12.2009 12:00:24

Hallo Karin
als Ansatz:
ab H2 nach unten kopieren:


{=WENN(B2="";"";INDEX(INDIREKT("'"&B2&"'!J2:J100");MAX(WENN(INDIREKT("'"&B2&"'!J2:J100")>0; ZEILE($1:$99))))) }

Matrixformel!

MfG Christian


  

Betrifft: AW: Mit Matrixformeln berechnete Werte übernehmen von: Karin
Geschrieben am: 21.12.2009 13:15:12

Hallo Christian,

deine Formel bringts total. Superherzlichen Dank!
Karin


Beiträge aus den Excel-Beispielen zum Thema "Mit Matrixformeln berechnete Werte übernehmen"