Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Teilergebnis - Gibts da eine Faustformel?

Teilergebnis - Gibts da eine Faustformel?
Thore
Hallo und guten Abend,
sagt gibt es eine "Faustformel" um bestehende Formeln mit Teilergebnis zu erweitern?
als Bsp.: =Summewenn(B:B;"*ABC*";Q:Q) wie müsste ich die hier einbauen?
Danke und Gruß
Thore

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Teilergebnis - Gibts da eine Faustformel?
07.06.2012 10:06:41
fcs
Hallo Thore,
hier dein Input ein bischen dürftig.
a) Was meinst du mit "Faustformel"?
b) In welche Richtung wilst du erweitern?
Wenn du nur mit Excel 2007 und neuer arbeitest, geht evtl. mit SUMMEWENNS was.
Eine weitere möglich besteht darin, in der Funktion SUMMENPODUKT mehrere Prüfbedingungen zu kombinieren.
oder auch Matrixformeln der Art
=SUMME(WENN(Zellbereich1=Bedingung;Zellbereich2;0)
wobei Zellbereich 1 und 2 dann die gleiche ANzahl Zellen habne müssen. Meist bekoomt man dies aber mit SUMMENPORDUKT einfcher hin.
Ansonsten schau dich mal auf der Seite http://www.excelformeln.de/formeln.html um.
Gruß
Franz
Anzeige
AW: Teilergebnis - Gibts da eine Faustformel?
09.06.2012 01:46:21
Thore
Hallo Franz,
das Problem vor dem ich immer wieder scheiter ist folgendes:
=Summewenn(B:B;"*ABC*";Q:Q) kann mit auch mit Zeichenfolgen innerhalb einer Zelle umgehen.
Wie hier bsphaft zu sehen "ABC".
Summeprodukt kann das nicht. Dafür kann Summeprodukt mit Filterergebnissen umgehen, und das wiederrum kann Summewenn nicht. Naja und Summeproukt kann leider auch keine Zeichenfolgen innerhalb einer Zelle erkennnen wie Summewenn.
Also was ich konkret suche ist eine Formel die eben beides kann.
=Summe bilden wenn Zeichenfolge gefunden und gerne auch im Filtermodus (Autofilter i.d.R)
Irgend eine Idee?
Danke und Gruß
Thore
Anzeige
AW: Teilergebnis - Gibts da eine Faustformel?
09.06.2012 08:46:37
fcs
Hallo Thore,
in Kombination mit entsprechenden Funktionen (.B. SUCHEN oder FINDEN) kann SUMMENPRODUKT auch Teilstrings in Texten finden.
Wenn du mit Autofilter arbeitest, dann kannst den gefilterten Datenbereich mit der FUNKTION TEILERGEBNIS auswerten.
Gruß
Franz
Tabelle1

 ABCDEF
1Ergebnis1051010 
2SuchwerteSpalte A: enthältoao   
3 Spalte D: enthältx   
4Feld01Feld02Feld03Feld04Feld05Feld06
7xxxoao5 x  
1311OAOdfr5 x  

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((NICHT(ISTFEHLER(SUCHEN(C2;A5:A16))))*(D5:D16="x")*(B5:B16))
C1=SUMMENPRODUKT((NICHT(ISTFEHLER(FINDEN(C2;A5:A16))))*(D5:D16="x")*B5:B16)
D1{=SUMME(WENN((NICHT(ISTFEHLER(SUCHEN(C2;A5:A16))))*(D5:D16="x"); B5:B16;0))}
E1=TEILERGEBNIS(9;B4:B16)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige