Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Spalte ohne leere Zellen
17.02.2023 12:02:33
Antonio
Hallo Gemeinde,
Ich versuche die Werte in "B:B" (Gelb) zu extraieren.
Der Erste Teil der Formel vergleicht Spalte"B:B" mit der Datenbank
und sucht mir nur die Werte in Gelb raus.
Der zweite Teil der Formel soll die leere Zellen löschen, also alles in "B32" hochrücken
Habe schon zwei Formel ausprobiert mit gleich Ergebniss
Formel in J32 und L32, man kann sie runterziehen zum Vergleich.
Die Leere Zellen sind immer noch da.
Hier eine Mappe:
https://www.herber.de/bbs/user/157883.xlsx
Bin auf ein wenig Hilfe angewiesen.
Vielen Dank im Voraus
LG Antonio

18
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Spalte ohne leere Zellen
17.02.2023 12:08:05
onur
1) Keine Formel kann irgenwas löschen.
2) Wo ist die "Datenbank"?
AW: Spalte ohne leere Zellen
17.02.2023 12:24:03
Antonio
Hallo onur,
Datenbank brauchs du nicht,
die Formel, durch kopieren, waren verschoben.
die Formel sind in "J32" und "L32"
Bitte runterziehen.
hier die Mappe nochmal:
https://www.herber.de/bbs/user/157884.xlsx
LG Antonio
AW: nachgefragt ...
17.02.2023 12:58:48
neopa
Hallo Antonio,
... Deine Formel in J39 ergibt für mich momentan wenig Sinn. Aus Deinen bisherigen Angaben entnehme ich, dass evtl. folgendes meinen könntest:
In J39: =WENN(B40="";"";INDEX(B:B;(ZEILE(A1)-1)*8+40)&"") und diese nach unten kopieren.
Gruß Werner
.. , - ...
Anzeige
AW: nachgefragt ...
17.02.2023 13:22:55
Antonio
Hallo Werner, bist wieder aktiv?
Deine Formel funzt auch, aber ich habe den Bereich, in der Musterdatei klein gehalten,
es geht natürlich weiter, von "B32" bis "B600"
es werden einige Werte Übersprungen
und ab den Bereich den ich in der Musterdatei angegeben habe
bleiben nach wie vor leere Zellen dazwischen.
Und da Du in der Formel "B:B" hast weiß ich nicht wo ich was ändern kann
LG Antonio
AW: d.h. dann wohl ...
17.02.2023 13:30:56
neopa
Hallo Antonio,
... dass ab diesen Bereich der konstante Abstand von 8 Zellen nicht mehr zutreffend ist. Bevor man dies jetzt genauer analysiert und doch mit einer AGGREGAT()-Formel arbeitet, würde ich Dir vorschlagen anstelle dessen eine Power Query Auswertung vorzunehmen und dort filtert.
Gruß Werner
.. , - ...
Anzeige
AW: d.h. dann wohl ...
17.02.2023 13:34:52
Antonio
Der Abstand von 8 ist konstant.
die Formel dafür hast du aufgestellt, weißt du noch Mappe 7
Power Query noch nie verwendet
LG
AW: wenn der Abstand immer konstant 8 ist ...
17.02.2023 13:42:04
neopa
Hallo Antonio,
... dann sollte die vorhin von mir aufgezeigte Formel auch zwischen rein keine Leerstellen aufweisen.
Mappe7? Dunkel erinnere ich mich an eine solche, aber eben auch nicht viel mehr. Kannst Du in einer hier neu eingestellten Datei aufzeigen, wo die jetzige Formel nicht mehr das gewünschte realisiert ?
Gruß Werner
.. , - ...
AW: wozu der von Dir eingefügte Formelteil? ...
17.02.2023 14:12:27
Dir
Hallo Antonio,
... und auch Deine Anpassung meiner Formel an die neue Startadresse war nicht korrekt.
In I32: =WENN(B48="";"";INDEX(B:B;(ZEILE(B1)-1)*8+32)&"") und diese nach unten kopieren.
Gruß Werner
.. , - ...
AW: wozu der von Dir eingefügte Formelteil? ...
17.02.2023 14:22:10
Dir
Ich habe jetzt nur deine Formel drin:
Userbild
Aber warum "B48" ?
AW: was meinst Du mit: warum "B48" ? owT
17.02.2023 14:47:31
neopa
Gruß Werner
.. , - ...
AW: wenn die Akkorde in "B32" anfangen owT
17.02.2023 14:50:59
Antonio
LG
AW: hmm, was meinst Du? owT
17.02.2023 15:48:46
neopa
Gruß Werner
.. , - ...
AW: Formel verstanden psst alles
17.02.2023 16:01:27
Antonio
Danke
;-)
Antonio
AW: bitteschön owT
17.02.2023 16:15:23
neopa
Gruß Werner
.. , - ...
AW: Spalte ohne leere Zellen
17.02.2023 12:39:56
Rudi
Hallo,
da sind keine Formeln in J32/ L32. Aber in 39. Warum beziehen die sich auf 40?
schreib doch mal dein Wunschergebnis in die Zellen.
Gruß
Rudi
Anzeige
AW: Spalte ohne leere Zellen
17.02.2023 12:54:11
Antonio
Hallo Rudi
habe selber gemerkt das alles verschoben war,
du kannst die Formel in J40 händisch verschieben hnd dort wo "B40" steht auf "B32" ändern
oder in Post4 von mir die neue Mappe
Ergebnis sollte sein das alle Werte untereinander stehen:
Durch din erste Teil der Formel kommen die Werte so an:
CMaj
CMaj
Fm
usw
so sollen sein:
CMaj
Cmaj
Fm
usw.
Fm

348 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige