Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

übertrag ohne leere zellen und sortierung

übertrag ohne leere zellen und sortierung
08.08.2019 09:34:11
Robert
hallo,
ich würde gerne von Spalte C die Namen in Spalte E übertragen jedoch ohne Leere Zellen, da hier durch den Sverweis leere Zellen entstanden sind.
Sortierung erfolgt dann nehme ich an wie gewöhnlich mit dem Sortierungsbutton bzw. filter.
Wie mach ich das?

12
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: übertrag ohne leere zellen und sortierung
08.08.2019 10:29:48
Robert
funktioniert irgendwie nicht
=WENNFEHLER(INDEX($C$3:$C$109;KKLEINSTE(WENN($D$3:$D$109="1";ZEILE(X$3:X$109));ZEILE(C3)));"")
Spalte C3-C200 Daten
Spalte D3-D200 1 od. Kein Wert (Kontrolle)
Spalte F soll die Auflistung ohne leere Zellen stattfinden
AW: übertrag ohne leere zellen und sortierung
08.08.2019 10:32:38
SF
Hola,
=WENNFEHLER(INDEX($C$3:$C$109;KKLEINSTE(WENN($D$3:$D$109=1;ZEILE(X$3:X$109)-2);ZEILE(C1)));"")
als Matrixformel abschließen.
Gruß,
steve1da
Anzeige
AW: übertrag ohne leere zellen und sortierung
08.08.2019 10:36:27
Robert
achja.. ich hab in der Spalte C namen stehen, keine Zahlen.. ich glaub das ist wichtig
AW: übertrag ohne leere zellen und sortierung
08.08.2019 10:48:21
SF
Hola,
 ich glaub das ist wichtig
natürlich ist das wichtig! Dann ändere das halt in der Formel.
Gruß,
steve1da
AW: übertrag ohne leere zellen und sortierung
08.08.2019 10:50:51
Robert
sorry,
wie mach ich das jetzt bitte?
AW: übertrag ohne leere zellen und sortierung
08.08.2019 10:52:38
SF
Hola,
sorry, verlesen. Was in C steht ist egal, das wird ja nur wiedergegeben.
Nimm meine Formel.
Gruß,
steve1da
AW: übertrag ohne leere zellen und sortierung
08.08.2019 10:58:50
Robert
perfekt jetzt hat es funktioniert
matrixformel, hab nur mit enter bestätigt ;)
Vielen lieben Dank. Bist the BEST
Geht auch nur mit Enter
08.08.2019 11:01:07
SF

=WENNFEHLER(INDEX($C$3:$C$309;AGGREGAT(15;6;ZEILE($C$3:$C$309)-2/($D$3:$D$309=1);ZEILE(A1)));"") 
Gruß,
steve1da
Anzeige
AW: nur bedingt, denn ...
08.08.2019 12:11:22
neopa
Hallo steve1da,
... sortieren lassen sich Formelergebnisse lediglich, wenn die Formelergebnisse durch ihre Werte ersetzt werden.
Außerdem wenn im Beispiel mal eine Zeile vor 2. noch eingefügt oder gelöscht werden sollte, müsste die Formel erst wieder angepasst werden. Das hatte ich schon mehrfach versucht Dir zu vermitteln.
Gruß Werner
.. , - ...
Ich gelobe Besserung! ;-) owT
08.08.2019 12:48:29
SF
AW: sortierte lückenlose Ausgabe und ohne {} ...
08.08.2019 12:19:14
neopa
Hallo Robert,
... nachfolgende Matrixfunktion(alität)sformel die keines spez. Formelabschluss wie eine klassische Matrixformel benötigt einfach nach unten kopieren. Wobei in der Formel die Teilprüfung (D$3:D$200=1) noch entfallen kann, wenn die 1 in Spalte D nie bei leeren Zellen in Spalten C steht.
Die Sortierung erfolgt aufwärts.
Arbeitsblatt mit dem Namen 'Tabelle2'
 CDEF
1    
2Namen  Namen sort.
3Paul1 Adam
4Fritz1 Bernd
5 1 Fritz
6Keiner  Gustav
7Adam1 Paul
8 1  
9    
10Gustav1  
11Bernd1  
12    

ZelleFormel
F3=WENNFEHLER(INDEX(C:C;AGGREGAT(15;6;ZEILE(C$3:C$200)/(C$3:C$200>"")/(D$3:D$200=1)/(ZÄHLENWENN(C$3:C$200;"&gt="&C$3:C$200)=AGGREGAT(14;6;ZÄHLENWENN(C$3:C$200;"&gt="&C$3:C$200)/(D$3:D$200=1);ZEILE()-ZEILE(F$2)));1));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß Werner
.. , - ...
Anzeige

351 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige