Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
984to988
984to988
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Liste ohne Leerzellen
16.06.2008 12:37:00
Cold
Hallo,
mit folgenden zwei Formeln lese ich aus den Spalten A und B nur die Zellen aus in denen ein Wert steht.
=WENN(ZEILE(1:1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000)); ZEILE(A1))) ) einfügen und runterkopieren
=WENN(ZEILE(1:1)>ANZAHL2(B:B);"";INDEX(B:B;KKLEINSTE(WENN(B$1:B$1000<>"";ZEILE($1:$1000)); ZEILE(B1))) ) einfügen und runterkopieren
funktioniert fehlerfrei!
Nun zu meinem eigentlichen Problem. Ich möchte nun die Werte beider Spalten in einer Spalte fortlaufend ohne Leerzellen und komme mit der Formel so nicht weiter. Wäre hier für einen Tipp oder Lösung dankbar.
Eine Lösung per Makro ist ausgeschlossen da Makros nicht erlaubt sind für das Projekt.
TCold

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
durch Erweiterung Deiner MATRIXFormel ...
16.06.2008 16:25:20
neopa
Hallo TCold,
... sollte eine Interpretation Deiner Aufgabenstellung lösbar sein. Und zwar so, dass zunächst alle Werte Spalte A und dann alle Werte Spalte B fortlaufend gelistet werden.

=WENN(ZEILE(A1)>ANZAHL2(A:B);"";WENN(ZEILE(A1)>ANZAHL2(A:A);INDEX(B:B;KKLEINSTE(WENN(B$1:B$9""; ZEILE($1:$9));ZEILE(A1)-ANZAHL2(A:A)));INDEX(A:A;KKLEINSTE(WENN(A$1:A$9"";ZEILE($1:$9));ZEILE(A1))) )) 


Auf die Suche nach einer Optimierung (Kürzung) habe ich zunächst verzichtet.
Wenn Du das anders willst, solltest Du angeben, ob es sich bei den Werten um alphanumerische Daten handelt oder nicht und wie die Daten gelistet werden sollen.
Gruß Werner
.. , - ...

Anzeige
AW: durch Erweiterung Deiner MATRIXFormel ...
16.06.2008 16:33:56
Cold
vielen Dank Werner.
Formel ist genau das was ich gesucht habe. Der Rest stellt nun kein Problem mehr dar.
Gruß TCold

AW: durch Erweiterung Deiner MATRIXFormel ...
16.06.2008 16:35:00
Cold
vielen Dank Werner
Genau solls sein den Rest krieg ich schon hin.
Gruß TCold

307 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige