Microsoft Excel

Herbers Excel/VBA-Archiv

Pull Down Menü mit Auswahl in 2010 | Herbers Excel-Forum


Betrifft: Pull Down Menü mit Auswahl in 2010 von: Tobiax
Geschrieben am: 08.08.2012 10:57:25

Hallo!

So war es bei Excel 2003:
Es gibt ein Blatt SPIELER. Dort sind in Spalte A alle Namen und in den weiteren Spalten viele Infos.
Es gibt ein Blatt TEAM. Dort kann ich in jeder Zelle in Spalte A per Drop Down Menü die Spieler aus dem Baltt SPIELER (Spalte A) auswählen.
Mithilfe von SVERWEIS aktualisieren sich dann alle weiteren Spalten auf dem Blatt TEAM.

Bei Excel 2010 ist dieses Drop Down Menü weg. Wie bekomme ich es wieder?

Tobiax ...

Bonusaufgabe (siehe Anhang). Das Drop Down Menü soll nur die Spieler der entsprechenden Positon anzeigen.
A2 - A3 sollen alles Spieler mit T aus Spalte B bei SPIELER anzeigen.
A5 - A8 sollen alles Spieler mit A aus Spalte B bei SPIELER anzeigen.
A10 - A15 sollen alles Spieler mit M aus Spalte B bei SPIELER anzeigen.
A17 - A19 sollen alles Spieler mit S aus Spalte B bei SPIELER anzeigen.

  

Betrifft: AW: Pull Down Menü mit Auswahl in 2010 von: Tobiax
Geschrieben am: 08.08.2012 10:59:20

Hier die Datei für die Bonusaufgabe:

https://www.herber.de/bbs/user/81326.xlsx


  

Betrifft: *LOL* - Optische Täuschung von: NoNet
Geschrieben am: 08.08.2012 11:36:40

Hallo Tobiax,

das ist ja mal lustig : Das Dropdown der Gültigkeitsliste auf Blatt "Team" ist unter Excel 2010 nicht "weg" - man sieht nur den Dropdownpfeil nicht, wenn der nicht fixierte Bereich (ab Spalte B) zu weit nach rechts gerollt wird. Rolle weiter nach links, dann erscheint der Auswahl-Pfeil wieder :



Die Bonusaufgaben überlasse ich für den Moment anderen Helfern ;-)

Salut, NoNet



http://www.exceltreffen.de/index.php?page=224


  

Betrifft: *LOL* - Optische Täuschung...schon in XL03... von: silex1
Geschrieben am: 08.08.2012 14:08:36

Hallo NoNet,

dies ist schon in XL03 möglich. Daher sollte man den Scrollbereich erst ab Spalte C beginnen und Spalte B auf die Breite des DropDownPfeil stellen.

VG René


  

Betrifft: AW: Pull Down Menü mit Auswahl in 2010 von: Josef Ehrensberger
Geschrieben am: 08.08.2012 23:54:19



« Gruß Sepp »



  

Betrifft: Bonus von: Rudi Maintaire
Geschrieben am: 08.08.2012 11:50:03

Hallo,

 CACBCCCD
1Hilfsspalten   
2TAMS
3AdlerAffolterAignerAbdellaoue
4AlmerAlvaro DominguezAlabaArnautovic
5AlomerovicAmedickAlhuthayfiAsamoah
6AmsifAndersonAminiAvdic

Namen in der Tabelle (geändert/ neu)
NameBezug
Position=SPIELER!$B$3:INDEX(SPIELER!$B:$B;ANZAHL2(SPIELER!$A:$A)+1)
Spieler=SPIELER!$A$3:INDEX(SPIELER!$A:$A;ANZAHL2(SPIELER!$A:$A)+1)

ZelleFormel
CA3{=WENN(ZEILE(CA1)>ZÄHLENWENN(Position;CA$2);"";INDEX(Spieler;KKLEINSTE(WENN(Position=CA$2;ZEILE(Position)-2);ZEILE(CA1))))}
CB3{=WENN(ZEILE(CB1)>ZÄHLENWENN(Position;CB$2);"";INDEX(Spieler;KKLEINSTE(WENN(Position=CB$2;ZEILE(Position)-2);ZEILE(CB1))))}
CC3{=WENN(ZEILE(CC1)>ZÄHLENWENN(Position;CC$2);"";INDEX(Spieler;KKLEINSTE(WENN(Position=CC$2;ZEILE(Position)-2);ZEILE(CC1))))}
CD3{=WENN(ZEILE(CD1)>ZÄHLENWENN(Position;CD$2);"";INDEX(Spieler;KKLEINSTE(WENN(Position=CD$2;ZEILE(Position)-2);ZEILE(CD1))))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.


Die Namen für die Gültigkeitslisten änderst du wie folgt
Tor =SPIELER!$CA$3:INDEX(SPIELER!$CA:$CA;ZÄHLENWENN(Position;"T")+2)
die anderen analog.

Gruß
Rudi


Beiträge aus den Excel-Beispielen zum Thema "Pull Down Menü mit Auswahl in 2010"