dynamisches Kreisdiagram mit Dropdown-Liste

Bild

Betrifft: dynamisches Kreisdiagram mit Dropdown-Liste
von: Rudi
Geschrieben am: 16.07.2015 13:36:47

Hallo zusammen,
ich stehe vor einem Problem.
Für eine monatliche Produktivitätsauswertung würde ich gerne die Maschine
sowie den Datumsbereich für ein Kreisdiagramm über eine Dropdown-Liste auswählen.
Das Datum soll jeweils aus einem Startzeitpunkt und einem Endzeitpunkt bestehen.
Zum besseren Verständnis habe ich mal eine Beispieldatei angehängt.
https://www.herber.de/bbs/user/98856.xlsx
Vielleicht kann mir jemand helfen.
Vielen Dank

Bild

Betrifft: nachgefragt ...
von: der neopa C
Geschrieben am: 16.07.2015 14:15:29
Hallo RRudi,
... wie soll denn Dein Diagramm für z.B. 01.07 bis 02.07 aussehen?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nachgefragt ...
von: Rudi
Geschrieben am: 16.07.2015 14:19:42
Hallo Werner,
das Diagramm vom 01.07 bis 02.07 soll dann jeweils den Mittelwert anzeigen.
Also Mittelwert Produktion, Mittelwert Rüsten und Mittelwert Störung
Gruß Rudi

Bild

Betrifft: das dynamische Kreisdiagramm
von: der neopa C
Geschrieben am: 16.07.2015 16:40:50
Hallo Rudi,
... würde ich z.B. so lösen. In einem (ausblendbaren) Hilfsspaltenbereich (im Beispiel bei mir Spalte A) würde ich die vorhandenen Datumswerte ermitteln (weil Du in 1:1 mit verbunden Zellen gearbeitet hast). Die dortige Hilfsspaltenformel einfach entsprechend weit ziehend nach unten kopieren.
Die Datenermittlung für den auszuwertenden Datumsbereich würde ich einem eigenen Tabellenbereich ermitteln (im Beispiel C10:F11) auf die dann die Diagrammauswertung zugreift. Die Ermittlungsformel einfach nach rechts kopieren. Für die Datenauswahl hab ich Dropdownzellen definiert. Dafür sind für die Datumsauswahl Bereichsnamen zu definieren.

 ABCDEFGHIJKLMNOPQR
1      01.07.201502.07.201503.07.201504.07.2015
2     MaschinePRODUKTIONRÜSTENSTÖRUNGPRODUKTIONRÜSTENSTÖRUNGPRODUKTIONRÜSTENSTÖRUNGPRODUKTIONRÜSTENSTÖRUNG
3     Maschine182,55%5,00%12,00%61,34%0,65%38,01%75,00%5,00%20,00%85,00%2,00%13,00%
4     Maschine281,82%5,00%13,00%82,19%0,00%17,81%82,19%0,00%17,81%82,19%0,00%17,81%
5     Maschine354,10%5,00%41,00%62,47%0,00%37,53%75,00%3,00%22,00%80,00%4,00%16,00%
6     Maschine468,42%10,00%22,00%68,44%0,00%31,56%68,44%0,00%31,56%68,44%0,00%31,56%
7                  
8                  
9Datum Auswertung gemäß Auswahl Maschine:Maschine3Datum von02.07.2015Datum bis04.07.2015      
10  PRODUKTIONRÜSTENSTÖRUNG            
1101.07.2015 Maschine372,49%2,33%25,18%            
1202.07.2015                 
1303.07.2015                 
1404.07.2015                 

Formeln der Tabelle
ZelleFormel
A11=WENNFEHLER(AGGREGAT(15;6;G$1:DB$1/(G$1:DB$1>B8); 1); "")
C11=H9
D11{=WENNFEHLER(MITTELWERT(WENN(($F3:$F7=$C11)*($G1:$DB1>=$J9)*($G1:$DB1<=$L9)*(G2:DB2=D$10); G$3:DB$7)); "")}
B13=WENNFEHLER(AGGREGAT(15;6;G$1:DB$1/(G$1:DB$1>A14); 1); "")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
H9Liste =$F$3:$F$6 
J9Liste =von 
L9Liste =bis 
Namen in Formeln
ZelleNameBezieht sich auf
J9von=Tabelle1!$A$11:INDEX(Tabelle1!$A:$A;ZEILE(Tabelle1!C$10)+ANZAHL(Tabelle1!$A:$A))
L9bis=INDEX(Tabelle1!$A:$A;MAX(11;VERGLEICH(Tabelle1!$J$9;Tabelle1!$A:$A;))):INDEX(Tabelle1!$A:$A;ZEILE(Tabelle1!$A10)+ANZAHL(Tabelle1!$A:$A))
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: das dynamische Kreisdiagramm
von: Rudi
Geschrieben am: 17.07.2015 14:06:49
Sehr gut,
herzlichen Dank.
Gruß Rudi

Bild

Betrifft: AW: das dynamische Kreisdiagramm
von: Rudi
Geschrieben am: 17.07.2015 14:08:19
Sehr gut,
vielen Dank. Werde es gleich mal testen
Gruß Rudi

Bild

Betrifft: AW: das dynamische Kreisdiagramm
von: Rudi
Geschrieben am: 22.07.2015 12:57:19
Hallo Werner,
mit etwas Verspätung hätte ich nochmal ein paar Fragen.
Ich habe jetzt alles so eingegeben wie von dir vorgeschlagen, dass Problem ist nur, das es bei mir die Datumswerte in Spalte A nicht ermittelt. Außerdem erscheint bei der Datengültigkeit die Fehlermeldung: "Die Quelle untersucht gerade einen möglichen Fehler. Möchten Sie den Vorgang fortsetzen?"
Vielleicht kannst du mir nochmals helfen.
Ich habe die Datei auch zur Hilfe nochmals beigefügt.
https://www.herber.de/bbs/user/99012.xlsx
Vielen Dank

Bild

Betrifft: Ursache: ein falsches Zeichen ...
von: der neopa C
Geschrieben am: 22.07.2015 14:20:07
Hallo Rudi,
... hatte sich in Deiner Formel in A11 versteckt.
Du kannst den Fehler selbst beheben. Lösche einfach zweimal das "D" in den zwei DB$1 und ersetze dies durch ein neu eingegebenes "D". Sollte jetzt funktionieren. Oder?
In der Formel ersetze noch die letzte 1 durch ZEILE(A1), damit Du die Formel auch nach unten ziehend kopieren kannst. Die Formel in A11 sieht danach also so aus:

=WENNFEHLER(AGGREGAT(15;6;G$1:DB$1/G$1:DB$1>B8);ZEILE(A1)); "")
Dann musst Du auch noch das Leerzeichen in Deiner Tabellenblattbezeichnung: "Tabelle1 " löschen und die Formeln für die Bereichsnamen sowie in J9 und L9 das Datumsformat zuweisen.
Gruß Werner
.. , - ...

Bild

Betrifft: ein für Dich möglicherweise wichtiger Hinweis ...
von: der neopa C
Geschrieben am: 22.07.2015 17:29:58
Hallo nochmal,
... der thread wird Morgen deaktiviert im Archiv "gelandet" sein. Keiner kann dann darauf mehr antworten. Einsehen kann man ihn deswegen trotzdem noch.
Wenn Du also noch eine Frage hierzu hast, müsstest Du einen neuen thread aufmachen und diesen als solchen im Betreff kennzeichnen und im neuen Beitrag auf folgenden Archivlink: https://www.herber.de/forum/archiv/1436to1440/t1436771.htm (dieser thread) verweisen.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "dynamisches Kreisdiagram mit Dropdown-Liste "