Dropdownlisten abhängigkeit

Bild

Betrifft: Dropdownlisten abhängigkeit
von: Finn
Geschrieben am: 24.08.2015 12:00:02

Hallo,
ich habe eine Tabelle.
In Spalte C möchte ich eine Dropdownliste mit verschiedenen Stati haben.
In Zeile D soll eine weitere Dropdownliste erscheinen, aber nur wenn eine bestimmte Auswahl in Spalte C getroffen wurde. Ansonsten sollen die Felder nicht beschreibbar sein. und in Zeile E soll man nur reinschreiben können, wenn in C und D ein Eintrag ist. Ist das möglich?
Danke schonmal!

Bild

Betrifft: AW: die Frage kann ich mit ja beantworten, ...
von: ... neopa C
Geschrieben am: 24.08.2015 12:23:32
Hallo Finn,
... um es konkreter tun zu können, bedarf Deinerseits der Einstellung einer kleinen Beispieldatei, aus der zu entnehmen ist, was Du hast und was Du planst.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: die Frage kann ich mit ja beantworten, ...
von: Finn
Geschrieben am: 24.08.2015 13:24:33
Da müsste jetzt die Datei sein:
https://www.herber.de/bbs/user/99799.xlsx

Bild

Betrifft: AW: mit benutzerdefinierter Datengültigkeit ...
von: ... neopa C
Geschrieben am: 24.08.2015 13:38:22
Hallo Finn,
... definiere den Bereichsnamen ABC =Absagegründe12[Absagegründe]
In C2:C### die Datengültigkeit: Liste mit einer (mangels Deiner Angabe nun von mir angenommenen) Bedingungsformel in Quelle, z.B. so:
=WENN(C2<>3;ABC;"") und in D2:D## =ANZAHL2(C2:D2)=2
Doch wisse, dass die Bedingungsauswahl nicht mehr gilt, wenn Du nachträglich (nach Wahl in D2 und oE2) den Wert in C2 einfach löscht.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit benutzerdefinierter Datengültigkeit ...
von: Finn
Geschrieben am: 24.08.2015 13:48:07
die auswahl in c habe ich ohne formel sondern via datenüberprüfung gemacht.
ich mcöhte das ganze so fest gesetzt haben, dass es nicht von jemand anderem änderbar ist. das soll die vorlage für kollegen sein, in der sie in C und D nur diese möglichkeiten haben und nichts anderes eintragen können.

Bild

Betrifft: AW: Vorschläge beruhen nur auf Datengültigkeit ...
von: ... neopa C
Geschrieben am: 25.08.2015 08:36:43
Hallo Finn
... damit kann bei normaler Anwendung in den entsprechenden Zellen nichts anders eingetragen werden als durch diese Datengültigkeit vorgegeben.
Es gibt zwar noch Möglichkeiten die Datengültigkeit durch Zellkopie "auszuhebeln" aber mit einem entsprechenden Blattschutz lies sich das einschränken. Doch so ein "Schutz" ist natürlich keine unumgängliche Sicherheit. Er reicht aber für die meisten Anwendungsfälle aus.
Was überhaupt nicht nicht verhindert werden kann, wäre ein nachträgliches Löschen einer bereits getroffenen Zellauswahl in Spalte C.
Gruß Werner
.. , - ...


Bild

Betrifft: AW: Vorschläge beruhen nur auf Datengültigkeit ...
von: Finn
Geschrieben am: 25.08.2015 12:40:46
Habe es jetzt mit einem dynamischen Dropdown geschafft. Trotzdem Danke :)

Bild

Betrifft: AW: damit bleibt die Problematik doch bestehen ...
von: ... neopa C
Geschrieben am: 25.08.2015 15:01:53
Hallo Finn,
... die Du eigentlich vermeiden wolltest, sie wird nur etwas verlagert.
Wenn Du jedoch der Meinung bist, dass Du die von Dir gewünschte Lösung gefunden hast, solltest Du diese auch hier auch veröffentlichen.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Dropdownlisten abhängigkeit"