Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1548to1552
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summewenn ohne die gefilterten Werte

Summewenn ohne die gefilterten Werte
31.03.2017 14:24:18
WalterK
Hallo,
Derzeit werden im Bereich D1:D3 die Summen der Werte ab D5 errechnet - und zwar mit Summewenn, getrennt nach den Plus- und Minusbeträgen.
Wenn ich die Liste nach E:E filtere (nach 1 oder 0) sollten sich die Summen im Bereich D1:D3 so anpassen, dass nur die sichtbaren Beträge addiert werden - quasi wie Teilergebnis - aber auch getrennt nach den Plus- und Minusbeträgen.
Ich müsste also Summewenn und Teilergebnis kombinieren.
Wie geht das?


Tabelle1
 ABCDEF
1  Summe aller Plus-Beträg195  
2  Summe aller Minus-Beträge-300  
3  Endergebnis-105  
4 NameBox-NrSummeWertung 
5 u510,00 1 
6 r6201 
7 f -500 
8 h7-1001 
9 t 220 
10 g22551 
11 b 880 
12 d -1500 
13      

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
D1=SUMMEWENN($D$5:$D$12;">0";$D$5:$D$12)  =SUMIF(R5C4:R12C4,">0",R5C4:R12C4)
D2=SUMMEWENN($D$5:$D$12;"<0";$D$5:$D$12)  =SUMIF(R5C4:R12C4,"<0",R5C4:R12C4)
D3=SUMME(D1;D2)  =SUM(R[-2]C,R[-1]C)
E5:E12=WENN(B5="";"";WENN(C5<>"";1;0))  =IF(RC[-3]="","",IF(RC[-2]<>"",1,0))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.15 einschl 64 Bit

Und hier noch die Datei:
https://www.herber.de/bbs/user/112544.xlsx
Besten Dank und Servus, Walter

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Danke WF, genau so!. Servus, Walter
31.03.2017 16:04:51
WalterK
Anzeige

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige