Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN-Formel ergibt #WERT - Wer kann es lösen?

Betrifft: SUMMEWENN-Formel ergibt #WERT - Wer kann es lösen? von: Memo
Geschrieben am: 18.08.2004 12:53:25

Hallo an alle,

habe folgende Formel eingegeben:

=SUMME(WENN($C$29:$G$37=X34;$N$29:$O$37;0);WENN($I$29:$M$37=X34;$Q$29:$R$37;0))

und erhalte ständig eine Fehlermeldung (#WERT). Wo liegt der Fehler?

Braucht Ihr genauere Angaben? Vermute, dass es nur eine Kleinigkeit ist, komme aber nicht darauf.

Vielen Dank,
Memo

  


Betrifft: AW: SUMMEWENN-Formel ergibt #WERT - Wer kann es lösen? von: Andy81
Geschrieben am: 18.08.2004 13:02:08

Hallo!

wenn ich das richtig sehe steht nach den "wenn" bedingungen nur ein ein Zellbereich und keine anweisung, was zu tun ist wenn die bedingung erfüllt ist.
Ich hoffe es hilft weiter.

Gruß
Andy81


  


Betrifft: AW: SUMMEWENN-Formel ergibt #WERT - Wer kann es lösen? von: Memo
Geschrieben am: 18.08.2004 13:06:49

Ich dachte durch die Summe-Angabe wird die erste Zahl (erste Wenn-Funktion) mit der zweiten Zahl (zweite Wenn-Funktion) automatisch summiert.

Ist dem nicht so?


  


Betrifft: AW: SUMMEWENN-Formel ergibt #WERT - Wer kann es lö von: Nico
Geschrieben am: 18.08.2004 13:08:15

Hi

=WENN((x34)=SUMME($C$29:$G$37);$N$29:$O$37;wenn((x34)=summe($I$29:$M$37);$Q$29:$R$37;0))

glaub ich. habs nicht probiert.

Gruß
Nico


  


Betrifft: AW: SUMMEWENN-Formel ergibt #WERT - Wer kann es lö von: Memo
Geschrieben am: 18.08.2004 13:10:28

Hallo Nico,

danke für die schnelle Hilfe, leider funktioniert Dein Vorschlag auch nicht. Erhalte wieder #WERT.

Was nu?

Gruß,
Memo


  


Betrifft: AW: SUMMEWENN-Formel ergibt #WERT - Wer kann es lö von: Nico
Geschrieben am: 18.08.2004 13:14:15

Hi

so vielleicht?

=WENN((x34)=SUMME($C$29:$G$37);summe($N$29:$O$37);wenn((x34)=summe($I$29:$M$37);summe($Q$29:$R$37);0)))

Gruß
Nico


  


Betrifft: Die letzte Klammer war zu viel ... von: Memo
Geschrieben am: 18.08.2004 13:20:24

Hallo Nico,

die letzte Klammer war zu viel, ohne diese funktioniert es. Allerdings kommt ein falscher Wert raus - und zwar 0. Eigentlich sollte 17 rauskommen.

Ich probiere mal, ob ich es mit Deiner Formel lösen kann.

Gruß und Danke,
Memo


  


Betrifft: AW: Die letzte Klammer war zu viel ... von: Nico
Geschrieben am: 18.08.2004 13:22:59

ok
ich geh erstmal mittag machen

bis später und viel erfolg

Nico


  


Betrifft: Hier die komplette Datei, vielleicht hilft das ... von: Memo
Geschrieben am: 18.08.2004 13:16:15

hoffe es erscheint auch ...

Gruß,
Memo


  


Betrifft: So, nun müsste aber die Datei dran sein: von: Memo
Geschrieben am: 18.08.2004 13:23:11


https://www.herber.de/bbs/user/9773.xls

Vielleicht ist mein Problem so verständlicher!?

Danke und Gruß,
Memo


  


Betrifft: AW: So, nun müsste aber die Datei dran sein: von: Panicman
Geschrieben am: 18.08.2004 14:25:24

Hallo Memo,

Matrixformel bei verbundenen Zellen sollte man sein lassen.
nimm lieber diese hier und passe auf die Bereiche auf.
AM34=SUMMENPRODUKT((C29:C37=X34)*(N29:N37)+(I29:I37=X34)*(Q29:Q37))
Kommt 17 raus.

Gruß
Holger


  


Betrifft: es funktioniert, dann war das Problem ... von: Memo
Geschrieben am: 18.08.2004 15:12:25

..., dass ich Zellenbereiche genommen habe, nicht wahr?

Ich habe nun auch eine Lösung gefunden, wobei diese wohl eher unkonventionell ist. Deine dürfte da schon die fachlich richtigere sein.

Gib mal diese Formel in AM33 ein:

=SUMMEWENN($C$29:$G$37;$X33;$N$29:$O$37)+SUMMEWENN($I$29:$M$37;$X33;$Q$29:$R$37)

Wie ist Deine Meinung dazu?

Vielen Dank für Deine Lösung!

Gruß,
Memo


  


Betrifft: Viele Wege führen nach ROM,... von: Panicman
Geschrieben am: 18.08.2004 16:24:33

Hallo Memo,

Scheint auch richtig zu sein. !!!
Nimm immer die Lösung die funktioniert und die du 100% verstehst, um sie evtl. abändern zu können. Wenn es geht, arbeite ohne Array-Formeln, wegen der Performance.
Ansonsten ist es doch völlig egal, wie man ans Ziel kommt. Hauptsache man kommt an.

Gruß
Holger


 

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN-Formel ergibt #WERT - Wer kann es lösen?"