Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

SUMMEWENN mit Bedingung und Zahl in gleicher Zelle

SUMMEWENN mit Bedingung und Zahl in gleicher Zelle
16.04.2015 08:55:57
Christian
Hallo,
ich habe das Problem, daß ich Zahlen addieren möchte nach einer Bedingung, die in der selben Zelle wie die Zahlen stehen. Beispiel 25U oder 3RU oder 13RU.
Ich habe als Notlösung das Tabellenblatt "Kalender" in zwei neue Tabellenblätter "aufgesplittet", das eine zieht nur die Zahlen raus per
=LINKS(Kalender!B4;ANZAHL(LINKS(Kalender!B4;SPALTE(1:1))*1))
und das andere den entsprechenden Text über
=WENN(ISTFEHLER(TEIL(Kalender!B4;LÄNGE(VERWEIS(9^9;LINKS(Kalender!B4;SPALTE(1:1))*1))+1;99));""; TEIL(Kalender!B4;LÄNGE(VERWEIS(9^9;LINKS(Kalender!B4;SPALTE(1:1))*1))+1;99))
Aber so ist die Bearbeitung extrem langsam.
Ich stelle mir vor, daß man das eleganter lösen kann, nur ich habe leider keinen Ansatzpunkt.
Kann mir da jemand einen Tip geben?
LG Christian

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: SUMMEWENN mit Bedingung und Zahl in gleicher Zelle
16.04.2015 10:44:47
ransi
Hall Christian
Von wievielen Datensätzen (Zellen) sprichst du da ?
ransi

AW: SUMMEWENN mit Bedingung und Zahl in gleicher Zelle
17.04.2015 14:33:28
Christian
Es sind 365*20 Zellen, also 7300.

hattest Du mal meinen Vorschlag getestet? ...owT
17.04.2015 15:46:14
der
Gruß Werner
.. , - ...

reduziere die Auswertung auf das notwendige ...
16.04.2015 16:41:08
der
Hallo Christian,
... die Formel =LINKS(Kalender!B4;ANZAHL(LINKS(Kalender!B4;SPALTE(1:1))*1)) hast Du ja sicher als Matrixformel abgeschlossen. Diese sucht sucht nun Kalender!B4 durch den Formelteil SPALTE(1:1) in 16384 Zeichen (so viele Spalten hat die Zeile) nach Ziffern. Wenn Deine Zeichenketten aber eh max. nur 5 Zeichen lang sind, würde schon SPALTE(A1:E1) in der Formel schon reichen. Das verlängert zwar die Formel, aber die Auswertung wird beschleunigt. Der zweite Matrixformel benötigt es gar nicht. Anstelle dessen kannst Du einfach =WECHSELN(Kalender!B4;[und hier Dein Zelladresse eingeben, wo Deine zuvor ermittelte Ziffernfolge des Textes steht]) und Du hast den Textteil ohne die beginnenden Ziffern
Gruß Werner
.. , - ...
Anzeige

382 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige