Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn eins und zwei zutrifft trage 3 ein | Herbers Excel-Forum


Betrifft: Wenn eins und zwei zutrifft trage 3 ein von: Cicero
Geschrieben am: 13.01.2010 08:48:20

Guten morgen,
kann mir bitte jemand helfen. Ich habe das Archiv schon durchgestöbert, aber nichts passendes gefunden.
Und zwar geht es um WENN,DANN.
Folgendes Szenario:
In Spalte A 1: steht ein Betrag oder das Feld ist leer.
In Spalte B 1: steht 0,00 oder leer.
In Spalte C 1: steht ein Wert entweder 0,00 oder grösser z.B. 4,45 ( hinterlegt ist die Formel =WENN(I6>0;G6+H6*I6;G6)~f~

So und jetz möchte ich folgende Formel:
In spalte d:
~f~=wenn(A1>0;A1;wenn(B1=0,00;B1; <b>nun zum eigentlichen Problem

wenn A1 das Feld leer ist und B1 das Feld leer ist füge in D1 den Inhalte aus Spalte C1 ein.

Ich bedanke mich schon im voraus für Eure Hilfe.
Angelika

  

Betrifft: AW: Wenn eins und zwei zutrifft trage 3 ein von: AndreasG
Geschrieben am: 13.01.2010 09:03:06

Hallo Angelika,

in D1: =WENN(UND(A1="";B1="";C1;und hier dann deine bestehende WENN-Formel aus D1)))

Grüße
Andreas


  

Betrifft: AW: Wenn eins und zwei zutrifft trage 3 ein von: Thomas Franz
Geschrieben am: 13.01.2010 09:11:12

kleiner Fehler: die Klammer nach der 2. UND-Bedingung fehlt:


=WENN(UND(A1="";B1="");C1;wenn(A1>0;A1;wenn(B1=0;B1; "sonstiger Wert")))


  

Betrifft: jau ;-) danke! o.w.t. von: AndreasG
Geschrieben am: 13.01.2010 09:28:02

.


  

Betrifft: AW: Wenn eins und zwei zutrifft trage 3 ein von: Michael
Geschrieben am: 13.01.2010 09:07:13

schau dir aml und(.... ) an
=WENN(UND(A1="";B1="");C1;"irgendwas")
diese Formel sollte in D1

Gruß
Michael


  

Betrifft: AW: Wenn eins und zwei zutrifft trage 3 ein von: Cicero
Geschrieben am: 13.01.2010 10:07:25

Hallo vielen Dank an alle
sorry dass die Antwort länger gedauert hat, aber ich musste erst alles testen.


diese Formel funktioniert
WENN(UND(A1="";B1="");C1;WENN(A1>0;A1;WENN(B1=0;B1;B1))) ~f~

jetzt habe ich diese Formel auf meine Spalten abgeändert
also Spalte
A1 = bei mir M2
B1 = bei mir N2
c1 = bei mir J2

Spalte J ~f~ =WENN(I2>0;G2+H2*I2;G2) ~f~
Spalte M ~f~ =WENN(K2="x";J2*50%;"") ~f~
Spalte N ~f~ =WENN(L2="x";"0,00";"")


und jetzt funktioniert fast alles. Nur wenn in Spalte N der Wert 0,00 drin steht zeigt er leer an, und in der Testtabelle zeigt er wie gewünscht 0,00 an. Woran kann das liegen ??

Könnt Ihr mir vielleicht nochmal helfen.

DANKE
Angelika


Beiträge aus den Excel-Beispielen zum Thema "Wenn eins und zwei zutrifft trage 3 ein"