Mein Sverweis rechnet nur das was er sieht!



Excel-Version: 2000
nach unten

Betrifft: Mein Sverweis rechnet nur das was er sieht!
von: Jeanne
Geschrieben am: 13.05.2002 - 14:48:15

Hallo Ihr Lieben,

Mein Problem ist folgendes:
Ich vergleiche mit Sverweis mehrere Monats-Tabellen und lasse mir dann bestimmte Spalten auswerten, sodaß im aktuellen Monat auch aktuelle Zahlen stehen. Es funktioniert aber nur, wenn der Vergleichsname auch vorhanden ist. Wie schaffe ich es, auch die Namen auszuwerten die im aktuellen Monat nicht mehr vorhanden sind?
Ich wäre für jede Idee dankbar.

Bis denne
Jeanne

nach oben   nach unten

Re: Mein Sverweis rechnet nur das was er sieht!
von: Daniel R.
Geschrieben am: 13.05.2002 - 15:20:57

Anhand Deiner Beschreibung ist es realtiv schwierig, die Ursache für das Nichtfunktionieren von Sverweis zu erklären.
Grundsätzlich:
Ein "Vergleichsname" muss vorhanden sein, ansonsten wird #NV ausgewiesen. Es gibt jedoch die Möglichkeit, Sverweis mit Hilfe der "Istfehler"- oder "Wenn"-Funktion zu verschachteln. Dabei können mehrere Tabellen nacheinander abgefragt und überprüft werden. Wenn Du mit diesen Angaben nicht weiter kommst, schicke ich Dir ein Beispiel. Das kann ich aber erst heute Abend tun.
Gruss Daniel R.
nach oben   nach unten

Re: Mein Sverweis rechnet nur das was er sieht!
von: Jeanne
Geschrieben am: 13.05.2002 - 15:45:55

Hallo Daniel,

Schick mir mal das Beispiel, irgendwie komme ich mit dem ISTFEHLER nicht so zurecht!, Danke aber schon mal im voraus.

Jeanne


nach oben   nach unten

Re: Mein Sverweis rechnet nur das was er sieht!
von: Daniel R.
Geschrieben am: 13.05.2002 - 21:02:00

Hallo Jeanne
Hier also das versprochene Beispiel. Es geht um folgendes:
Ich habe drei Tabellen angelegt: Tabelle 1 -2 und -3. In Tabelle 1 Spalte A3-A5 steht die verschachtelte Sverweis-Funktion. In Spalte B3-B5 kann ich Werte eingeben. Die Funktion durchsucht nun zuerst Tabelle 2 nach dem eingegebenen Wert, wobei in Tabelle 2 Spalte A3-A5 die zu überprüfenden Werte und daneben, also in Spalte B3-B5 die Bezeichnungen stehen. Wenn in Tabelle 2 keine Übereinstimmung gefunden wird, sucht die Funktion in Tabelle 3 nach einer Übereinstimmung ansonsten wird "Keine Nummer" ausgegeben. Grundsätzlich kann diese Funktion noch weiter verschachtelt werden. Allerdings sind in einer Zelle max 1024 Zeichen möglich. Wenn Du mehrere Tabellen durchsuchen willst, ist das Ganze nur noch mit VBA lösbar. Falls erforderlich, kann ich Dir die Beispieldatei auch mailen. Ebenfalls könnte ich Dir das Beispiel in VBA übermitteln.
Ich hoffe Dir damit weiter zu helfen. Sonst melde Dich noch mal.
Gruss Daniel

=WENN(B3>0;WENN(UND(ISTFEHLER(SVERWEIS(B3;Tabelle2!$A$3:$B$5;2;FALSCH));ISTFEHLER(SVERWEIS(B3;Tabelle3!$A$3:$B$5;2;FALSCH)));"Keine Nummer";WENN(ISTFEHLER(SVERWEIS(B3;Tabelle2!$A$3:$B$5;2;FALSCH));SVERWEIS(B3;Tabelle3!$A$3:$B$5;2;FALSCH);SVERWEIS(B3;Tabelle2!$A$3:$B$5;2;FALSCH)));0)

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Mein Sverweis rechnet nur das was er sieht!"