Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Sverweis, Wenn dann -> richtige Preise auswählen

Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 11:51:00
Till
Hallo Excel Freunde,
ich habe mal wieder ein Problem.
In folgender Liste muss ich mehrere Entscheidungen durchführen.
Im Bildanhang die Liste:
Userbild
D.h. in einer Kalkulation stehen jetzt nur 20 Stück von Produkt A und Excel soll dann den richtigen Preis (also in diesem Fall 2300) dazu aus der Wertemenge suchen, oder anderes Beispiel: 23 Stück Produkt B = Preis: 2320.
Wie kann man mit Sverweis oder Wenn Formeln Excel dazubringen erst mal in der richtigen Spalte zu suchen (abhängig vom gewünschten Produkt) und dann auch noch den richtigen Preis in Abhängigkeit der Stückzahl zu wählen?
Für hilfreiche Tipps wäre ich dankbar!
Vielen Dank schon mal im Voraus!
Gruß Till

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 11:53:00
David
Hallo Till,
ermittle mit VERGLEICH die Spalte und definiere die Suchmatrix für den SVERWEIS dann per BEREICH.VERSCHIEBEN
Gruß
David
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 12:11:00
David
zum Beispiel so:
Tabellenblattname: Tabelle1
 

A

B

C

D

1

Anzahl

Produkt A

Produkt B

Produkt C

2

10

2300

2430

2820

3

20

2210

2320

2630

4

50

2130

2250

2520

5

100

2070

2190

2430

6

 

 

 

 

7

gesucht:

Produkt B

 

 

8

 

20

 

 

9

 

 

 

 

10

Preis:

2320

 

 


Benutzte Formeln:
B10: =SVERWEIS(B8;BEREICH.VERSCHIEBEN(A1;;;5;VERGLEICH(B7;A1:D1;0));VERGLEICH(B7;A1:D1;0);1)
Rückmeldung wäre nett.
Gruß
David
Anzeige
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 12:34:00
Rudi
Hallo David,
ist das nicht ein bisschen kompliziert?
=sverweis(b8;A1:D5;vergleich(B7;A1:D1;0);1)
Gruß
Rudi
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 13:05:00
Till
Hallo David,
das hat schon mal sehr gut geklappt. Der Ansatz steht!
Ein kleiner Fehler ist noch drin, den ich nicht rausbekomme.
Z.B. wenn ich für ProduktA 150 Stück oder mehr habe, nimmt Excel immer nur noch die Preise für die 100 Stück.
Welche Kleinigkeit ist da noch falsch?
Gruß Till
P.S.: Rudis Formel klappt dabei an der Stelle (Danke auch dafür!)
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 13:07:00
David
Das liegt an Sverweis, durch die Option ;1 sucht er auch Werte, die nicht genau einem in der Tabelle entspricht. Schau dir mal die Hilfe dazu an mit der Option "WAHR", dort ist das erklärt.
Gruß
David
Anzeige
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 13:18:27
Till
Alles klar,
vielen Dank für die ausführliche Hilfe!
Gruß Till
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 13:05:00
David
Hallo Rudi,
stimmt, so geht es auch - und das noch einfacher. ;-)
Irgendwie spukte mir da noch was anderes im Hinterkopf rum, desegen habe ich wohl ein wenig "umd die Ecke" gedacht.
Gruß
David
AW: Sverweis, Wenn dann -> richtige Preise auswählen
26.11.2008 12:13:00
Till
Hallo David,
vielen Dank für Deine schnelle Antwort. Gib mal bitte ein kurzes Beispiel (z.B. 20 Stück von Produkt A).
So etwas hab ich noch nicht gemacht. Da bin ich eher ein bißchen dumm.
Vielen Dank !
Gruß Till
IE/Firefox: <F5> ;-)
26.11.2008 12:14:54
David
Gruß
David

319 Forumthreads zu ähnlichen Themen


Hallo zusammen,
ich bräuchte zu folgendem Thema eure Hilfe:
und zwar geht es um den Abgleich zweier Arbeitmappen. In der ersten Arbeitsmappe befinden sich die Infos, aus der ein Ergebnis für die zweite Arbeitsmappe ausgelesen werden soll. Hab mal ne Beispieldatei angehängt:
https://...
Anzeige

Hallo
Ich stehe hier gerade auf dem Schlauch und wollte Euch darum um Hilfe bitten.
Ich möchte, dass in Zelle D automatisch das gleiche erscheint, wie in Zelle A.
Mit folgender Ausnahme:
Wenn ich Zelle A unter anderem das Wort "Hund" vorkommt, soll in Zelle D an gleicher Stelle...

Hallo guten Morgen liebe Helfer,
ich komme mit einer Wenn Dann Formel im VBA nicht klar. Wer kann mir bitte helfen.
WENN Zelle C1 = OK DANN starte Makro1 sonst MsgBox "Eingabe leider falsch"
Ich schaffe es einfach nicht das ich innerhalb der Abfrage ein Makro starten lasse möchte we...
Anzeige

Hallo Forum,
stehe gerade völlig auf dem Schlauch. Habe folgende Formel, die ich um eine weitere WENN-Abfrage erweitern muss. Nur wo?
=WENN(ISTFEHLER(D2-SVERWEIS(B2;Tabelle1;3;FALSCH));"Nicht vorhanden";D2-SVERWEIS(B2;Tabelle1;3;FALSCH))
Jetzt soll noch rein: Wenn die Zelle D2 in T...

Hallo,
montagsgemäß steh ich gerade auf dem Schlauch und benötoge Hilfe für folgendes Problem:
ich habe mind. 10 Werte in % von 50% bis 110%
In den Zellen A1 bis A10 steht ein Text, dahinter also in B1 bis B10 die Prozentwerte.
Dann steht in C1 ein Objektspezifischer Wert/ein E...

Hi zusammen,
wie kann ich denn folgende Abfrage machen:
Wenn sheet("data") NICHT VORHANDEN, dann Abbruch
Danke
Mandy
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige