Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
284to288
284to288
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

SVERWEIS mit UND-verknüpften Bedingungen

SVERWEIS mit UND-verknüpften Bedingungen
30.07.2003 13:54:39
Matthias H.
Hallo,

ich benutze die Funktion SVERWEIS um einem Textbegriff (Land) einen Zahlenwert (Währungsumrechnung) zuzuordnen:

=SVERWEIS(E285;Bestand!$P$4:$R$81;2;FALSCH)

Da pro Land aber meist eine Währung UND eine Unterwährung (Mark/Pfennig) existiert möchte ich die Zuordnung des Zahlenwertes sowohl vom Land als auch von der Währung abhängig machen.
Wie kann ich das realisiseren?

Gruß
Matthias

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Hilfsspalte in Bestand
30.07.2003 14:17:05
Ingo
HAllo Matthias,

Baue in deine Bestandstabelle am anfang eine hilfsspalte ein mit dem inhalt

=Land & " " & Währung

und greife anschließend mit diesem schlüssel über sverweis darauf zu:

Gruß Ingo


AW: Hilfsspalte in Bestand
30.07.2003 14:34:16
Matthias H.
Hallo Ingo,
das habe ich in ähnlicher Form schon ausprobiert, hat aber nicht funktioniert:

=SVERWEIS(E292&D292;Bestand!$P$5:$S$80;2;FALSCH)
Spalte D: Währung
Spalte E: Land

Spalte P: Land
Spalte Q: Wechselkurs
Spalte R: Währung
Spalte S: Land&Währung

Als Ergebnis kommt #NV
Wenn ich die & Verbindung weglasse, funktionert es...

Siehst Du einen Fehler?

Gruß Matthias


Anzeige
AW: Hilfsspalte in Bestand
30.07.2003 17:17:18
ingo
Hallo Matthias,
Du fügst eine neue spalte p ein und schreibst dorthin:

in zelle p5:

=t5 bzw =q5 & s5 (t5 ist ja dann die alte spalte s5 ...

der sverweis sieht dann folgendermassen aus:

=SVERWEIS(E292&D292;Bestand!$P$5:$T$80;3;FALSCH)

die spalte Land&währung muß in der matrix in der ersten spalte stehen, damit sverweis damit arbeiten kann.

Ich hoffe, Du kommst damit zurecht

Gruß Ingo


Danke
31.07.2003 18:45:13
Matthias H.
Hallo Ingo,

ich wußte nicht daß der "Suchbegriff" in der ersten Spalte der Matrix stehen muß. Daran lag es also. Vielen Dank!

Gruß
Matthias


Anzeige

374 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige