Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS mit Mehrfachabfrage und Größer-Kleiner Fu

Betrifft: SVERWEIS mit Mehrfachabfrage und Größer-Kleiner Fu von: Alex
Geschrieben am: 28.08.2014 12:22:10

Hallo Excel Anwender,

ich habe folgende SVERWEIS Funktion mit viel Mühe "zusammengeklickt" ;-)



Dabei wird in Feld B6 die Antwort AS_101; AS_102; AS_103 oder AS_104 als Ergebnis ausgegeben wenn die Kriterien der Matrix J3 bis J6 in den Feldern A3 bis A6 erfüllt werden. Gibt man in den Feldern A3 bis A6 etwas anderes ein als es die Matrix kennt wird wie im Beispiel zu sehen "Keine WPS Vorhanden" angezeigt.

Die Formel die ich in B6 verwende ist:
=WENN(ISTNV(SVERWEIS(A3&B3&C3&D3;J3:K6;2;FALSCH)) = WAHR; "KEINE WPS VORHANDEN"; SVERWEIS(A3&B3&C3&D3;J3:K6;2;FALSCH))

oder als Bild:


Mit dieser Funktionalität bin ich schon mal ganz zufrieden. Jetzt möchte ich aber dass wenn in D3 Werte größer 3 und kleiner/gleich 6 eingegeben werden immer das Ergebnis beispielsweise AS_103 ist. Gibt jemand in D3 Werte größer
6 und kleiner/gleich 10 ein soll z.B. immer das Ergebnis AS_104 ausgegeben werden. Gibt jemand Werte in D3 ein welche außerhalb dieser Grenzen liegen möchte ich dass "Keine WPS vorhanden" erscheint.

Ich hoffe ich konnte mein Problem verständlich erklären...?!

Für Eure Unterstützung herzlichen Dank im Voraus

Gruß
Alex

  

Betrifft: Warum als Bild ? von: ransi
Geschrieben am: 28.08.2014 12:26:06

Hallo Alex

Soll man deinen Screenshot abtippen ?
Warum lädst du nicht das Excelfile hoch ?

ransi


  

Betrifft: AW: Warum als Bild ? von: Alex
Geschrieben am: 28.08.2014 12:46:24

Hallo,

sorry nicht nachgedacht:

https://www.herber.de/bbs/user/92358.xlsx


  

Betrifft: AW: Warum als Bild ? von: Alex
Geschrieben am: 28.08.2014 15:10:51

...keiner eine Idee???


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS mit Mehrfachabfrage und Größer-Kleiner Fu"