Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Ausgabewert berechnen nur bei größer als ...

Betrifft: Ausgabewert berechnen nur bei größer als ... von: Peter Schmidt
Geschrieben am: 12.11.2012 22:18:21

Hallo liebe Forumsgemeinde!
Vielleicht weis jemand Rat für folgendes Problem.
Ich habe ein Exel-Arbeitsblatt erstellt (bin Laie), welches mit ein paar einfachen Formel, die ich mir aus dem WEB zusammengesucht habe, soweit ganz gut funktioniert. Nur eines bekomme ich - über die bedingte Formatierung - nicht hin.

Ich habe einen Zeitwert '6:00' in Spalte A und einen Zeitwert '6:10' in Spalte B. In Spalte C gibt mir die Formel =WENN(B1=0;0;B2-A1) den Differenzwert in Minuten [m] aus.
Zusätzlich zeigt Spalte C über die Zellenformatierung [m];[=0]"";Standard gar keinen Wert an, weil es sein kann, das beispielsweise in Spalte A schon '6:00' steht, in Spalte B aber noch kein Zeiteintrag.

Ich möchte nun zusätzlich haben, das in Spalte C Excel in keiner Zelle eine Berechnung durchführt, resp. anzeigt oder kummuliert, die einen bestimmten Wert unterschreitet, also z.B. kleiner ist als 15 Minuten. Oder andersherum nur dort eine Berechnung durchführt, wo ein bestimmter Wert z.B 15 Minuten überschritten wird, bzw. ab 16 Minuten.

Ich dachte mir, das dieser Weg vielleicht gangbar ist, um im Endergebnis nur die Minutenwerte unten multiplizieren zu lassen, die eben diesen bestimmten Wert haben. Excel will nämlich ums verrecken keine Zelle die diese Bedingung erfüllt, über die bedingte Formatierung mit den vorgegebenen Zellenformatierungen farbig hinterlegen resp. die anderen Zellen auslassen.
Ich hoffe jemand kann mir helfen. Vielen Dank im Voraus!

  

Betrifft: AW: Ausgabewert berechnen nur bei größer als ... von: hary
Geschrieben am: 13.11.2012 07:26:28

Hallo Peter

Tabelle1

 ABC
106:0006:00 
206:0006:10 
3  06:1515
4     

verwendete Formeln
Zelle Formel Bereich
C2 =WENN(ODER(B1=0;B2-A1<ZEITWERT("00:15"));0;B2-A1) 
C3 =WENN(ODER(B2=0;B3-A2<ZEITWERT("00:15"));0;B3-A2) 

Tabellendarstellung in Foren Version 5.30


gruss hary


  

Betrifft: AW: Ausgabewert berechnen nur bei größer als ... von: Peter Schmidt
Geschrieben am: 13.11.2012 19:20:44

Vielen Dank, hary
für die Hilfe. Damit kam ich weiter. Zwar habe ich etwas falsche Angaben geliefert
(natürlich wollte ich eine Differenz in derselben Zeile in einer anderen Spalte abhängig vom Wert angezeigt bekommen),
aber ich konnte die Formel nun entsprechend leicht anpassen und auch farblich formatieren.

Das Arbeitsblatt funktioniert nun so wie ich es wollte.

Vielen Dank noch mal,
lG,Peter


 

Beiträge aus den Excel-Beispielen zum Thema "Ausgabewert berechnen nur bei größer als ... "