Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Monat kleiner als...

Betrifft: Wenn Monat kleiner als... von: Thomas R.
Geschrieben am: 23.11.2014 11:16:20

Hallo zusammen,
bin neu hier und überfalle euch (dreist wie ich bin) direkt mit einem kleinen Problem.

Was ist an dieser Formel falsch:

=WENN(MONAT(A257<7);MONATSENDE(A257;3);DATUM(2014;12;31))

In Worten: Wenn der Kalendermonat kleiner Juli ist, dann sollen auf das jeweilige Monatsende zwei Monate draufgepackt werden. Ist der Monat aus A257 größer als Juli, soll das Datum 31.12.2014 ausgegeben werden.

Aktuell wird "kleiner 7" in der Berechnung gänzlich ignoriert...

Herzlichen Dank vorab!

VG,
Thomas R.

  

Betrifft: AW: Wenn Monat kleiner als... von: Hajo_Zi
Geschrieben am: 23.11.2014 11:18:11

Hallo Thomas,

Klammern.

 =WENN(MONAT(A257)<7;MONATSENDE(A257;3);DATUM(2014;12;31))

GrußformelHomepage


  

Betrifft: genau genommen ... von: neopa C (paneo)
Geschrieben am: 23.11.2014 11:56:43

Hallo Thomas,

.. musst Du zumindest noch prüfen ob die Zelle nicht leer ist. Und nachfolgend auch noch eine Alternative für das Fixdatum 31.12.14:

=WENN(A257="";"";WENN(MONAT(A257)<7;MONATSENDE(A257;3);"31.12.14"*1))
Gruß Werner
.. , - ...


  

Betrifft: AW: genau genommen ... von: Thomas R.
Geschrieben am: 23.11.2014 15:49:50

Hallo Werner,
Danke für deine Antwort. Trotzdem wird "WENN kleiner als" ignoriert...


  

Betrifft: dann stehen in Deinen Datenzellen ... von: neopa C (paneo)
Geschrieben am: 23.11.2014 16:11:13

Hallo Thomas,

... keine echten Excel-Datumswerte sondern Textwerte die wie Datumsangaben aussehen.

Wie sehen denn diese bei Dir aus?

Gruß Werner
.. , - ...