Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweis mit meheren gleichen Daten

Betrifft: SVerweis mit meheren gleichen Daten von: d.weihrather@hotmail.de
Geschrieben am: 04.09.2020 12:39:10

Hallo, ich hab eine Exceldatei und versuche einen Abgleich zu schreiben, der mir ausgeben soll ob etwas vorhanden ist oder nicht, mit ja/nein.

Ich hab 2 Kriterien nach denen Ausgewertet werden soll. Also ein Masterkriterium in ein Spezifisches.
Mein Problem ist, dass das Masterkriterium vor jedem Spezifischen steht, sodass ich keinen Sverweis nutzen kann.
Kann mir jemand helfen?

Betrifft: AW: (D)eine (Beispiel)datei könnte aufklären owT
von: neopa C
Geschrieben am: 04.09.2020 12:44:14

Gruß Werner
.. , - ...

Betrifft: AW: (D)eine (Beispiel)datei könnte aufklären owT
von: d.weihrather@hotmail.de
Geschrieben am: 04.09.2020 12:56:20

https://www.herber.de/bbs/user/140045.xlsx

Betrifft: AW: mit ZÄHLENWENNS() ...
von: neopa C
Geschrieben am: 04.09.2020 13:15:16

Hallo,

... wenn es um die Datenwerte in Spalte C geht.

In D5: =WENN(ZÄHLENWENNS(Quelle!A:A;A5;Quelle!B:B;C5);"ja";"nein")

und nach unten kopieren.

Gruß Werner
.. , - ...

Betrifft: ne simple Kombi
von: WF
Geschrieben am: 04.09.2020 12:56:50

Hi,

=WENNFEHLER(WENN(VERGLEICH("*Master*"&"*spez1*";A1:A99;0);"ja");"nein")

WF

Betrifft: AW: ne simple Kombi
von: d.weihrather@hotmail.de
Geschrieben am: 04.09.2020 12:58:57

Also er soll nach DP Id gefsucht werden und dann abgeglichen werden.

Allerdings hat die Ursprungsdatei mehr als 1000 Datensätze, deshalb ist eine Formellösung nötig...
U

Betrifft: A99 in A9999 ändern bekommst Du hin.
von: WF
Geschrieben am: 04.09.2020 13:03:36

Ich bin zuversichtlich.

Betrifft: AW: A99 in A9999 ändern bekommst Du hin.
von: DW
Geschrieben am: 04.09.2020 13:27:18

die Kriterien sind im verschieden Spalten.
Bsp Datei ist online...
Bei dem Suchbereich wird doch nu Spalte abgeglichen.

Betrifft: AW: A99 in A9999 ändern bekommst Du hin.
von: DW
Geschrieben am: 04.09.2020 13:28:55

die Kriterien sind im verschieden Spalten.
Bsp Datei ist online...
Bei dem Suchbereich wird doch nu Spalte abgeglichen.

Betrifft: AW: A99 in A9999 ändern bekommst Du hin.
von: DW
Geschrieben am: 04.09.2020 13:31:38

aaber, die idee ist gut, werde die Spaöten zusammführen, dann sind die daten wieder einmalig und ich spare mir eine komplizierte Matrix funktion.

Betrifft: AW: A99 in A9999 ändern bekommst Du hin.
von: Werner
Geschrieben am: 04.09.2020 14:21:43

Hallo,

und was ist mit dem Vorschlag von neopa C ?

Oder gibt es einen Grund weshalb du ihn ignorierst?

Gruß Werner

Beiträge aus dem Excel-Forum zum Thema "SVerweis mit meheren gleichen Daten"