Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Nächstliegenden Wert aus Matrix finden

Betrifft: Nächstliegenden Wert aus Matrix finden von: Kathrin
Geschrieben am: 09.09.2020 17:19:15

Guten Tag zusammen,

ich habe eine Tabelle mit diversen Rechnungen. Jeder Rechnung ist eine Warengruppe und ein Rabattsatz zugeordnet. In einer zweiten Übersicht gibt es verschiedene Provisionssätze für unterschiedliche Rabattsätze und Warengruppen. Ich möchte nun den Rechnungen die entsprechenden Provisionssätze zuweisen. Zum besseren Verständnis dient (hoffentlich) die Beispieltabelle.

https://www.herber.de/bbs/user/140154.xlsx

Vielen Dank im Voraus.

Betrifft: Unzulässige Daten
von: lupo1
Geschrieben am: 09.09.2020 17:40:35

D2: =WENNFEHLER(SVERWEIS(C2;INDEX(K:K;VERGLEICH(B2;J:J;)):INDEX(L:L;VERGLEICH(B2;J:J));2);)

Es fehlen Extrema-Vereinbarungen.

Betrifft: AW: Nächstliegenden Wert aus Matrix finden
von: Daniel
Geschrieben am: 09.09.2020 17:50:11

Hi
das klappt im Prinzip mit dieser Formel (D2)

=SVERWEIS(C2;BEREICH.VERSCHIEBEN(INDEX(K:K;VERGLEICH(B2;J:J;0));0;0;ZÄHLENWENN(J:J;B2);2);2;WAHR)

allerdings musst du deine Liste mit den Provisionssätzen so aufbauen:
1. die Liste muss als AB-Liste geschrieben sein, du musst als Wert den KLEINSTEN Rabattsatz eintragen, ab dem der dazugehörige Prov.Satz gilt.
2. innerhalb einer Warengruppe muss die Liste nach dem Rabattwert aufsteigend sortiert sein.

die Warengruppen als ganzes müssen nicht zwingend sortiert angeordnet sein.
Gruß Daniel

Betrifft: AW: Nächstliegenden Wert aus Matrix finden
von: Kathrin
Geschrieben am: 10.09.2020 08:15:09

Guten Morgen,

vielen Dank für die schnelle Hilfe. Damit kann ich arbeiten. Ich muss "nur" - wie von Daniel geschrieben - jeweils den kleinsten Rabattsatz eintragen.

Wünsche einen schönen Tag!

VG
Kathrin

Beiträge aus dem Excel-Forum zum Thema "Nächstliegenden Wert aus Matrix finden"