WennDannSonst: drei alternative Wenn-Bedingungen

Bild

Betrifft: WennDannSonst: drei alternative Wenn-Bedingungen
von: Carle
Geschrieben am: 12.06.2015 21:41:54

Hallo!
Ich möchte eine WennDannSonst Funktion erstellen. Die Besonderheit (für mich) besteht darin, dass ich drei alternative Wenn-Bedingungen habe.
Und zwar wird in den Zellen einer Spalte (hier: C) der Wochentag abgekürzt angezeigt (Format: Mo,Di etc.). Nun möchte ich, dass in der jeweiligen Zelle rechts davon immer dann ein Ausrufezeichen erscheint, wenn der Wochentag Fr, Sa oder So hinterlegt ist. Geht das auf elegante Art oder nur über eine, wie ich vermute, umständliche und lagen Verschachtelung der Funktion?
Vielen Dank für Tipps
Carle

Bild

Betrifft: =WENN(SUMME((C1={"Fr";"Sa";"So"})*1);"!";"")
von: WF
Geschrieben am: 12.06.2015 22:12:06
.

Bild

Betrifft: =WENN(ODER(C1="FR";C1="SA";C1="SO");"!";"")
von: JACK_D
Geschrieben am: 12.06.2015 23:02:42
.

Bild

Betrifft: =WENN(ABS(CODE(C1)-76,5)=6,5;"!";"")
von: lupo1
Geschrieben am: 13.06.2015 08:54:01
.

Bild

Betrifft: =WENN(REST(CODE(C2);13)=5;"!";"")
von: lupo1
Geschrieben am: 13.06.2015 08:56:29
.

Bild

Betrifft: =WENN(REST(CODE(C1);9)=5;"";"!")
von: lupo1
Geschrieben am: 13.06.2015 09:03:28
.

Bild

Betrifft: Bei kleinbuchstaben geht Code in die Hose
von: WF
Geschrieben am: 13.06.2015 10:15:52
.

Bild

Betrifft: Gültigkeitsliste verwenden :-)
von: lupo1
Geschrieben am: 13.06.2015 11:32:44
.

Bild

Betrifft: nicht ganz auszuschließen wäre aber auch ...
von: der neopa C
Geschrieben am: 13.06.2015 11:21:00
Hallo Carle,
... dass Du, so wie Du schreibst: "...der Wochentag abgekürzt angezeigt (Format: Mo,Di etc.).... ", in Spalte C echte Excel-Datumsdaten zu stehen hast, die Du mit benutzerdefinierten Zahlenformat: TTT formatiert hast und die die von Dir gelistete Anzeige ergibt.
Dann folgende Formel:


=WENN(REST(C1+1;7)<3;"!";"")
Gruß Werner
.. , - ...

Bild

Betrifft: =WENN(WOCHENTAG(G1;2)>4;"!";"")
von: RPP63
Geschrieben am: 13.06.2015 11:22:47
Hi!
Wenn es Ein Datum im Format TTT ist (siehe TE: (Format: Mo,Di etc.)), dann natürlich:
=WENN(WOCHENTAG(G1;2)>4;"!";"")
Gruß Ralf

 Bild

Beiträge aus den Excel-Beispielen zum Thema "WennDannSonst: drei alternative Wenn-Bedingungen"