Zellen Wertbedingt ergänzen?

Bild

Betrifft: Zellen Wertbedingt ergänzen?
von: Ralf
Geschrieben am: 12.06.2015 14:47:32

Hallo zusammen,
in anliegender Tabelle kann man die Werte "p1" bis "p4" eintragen und damit eine zetiliche Planung erstellen.
Bisher würde ich die Blöcke (wie ersichtlich) kopieren und einfügen, aber kann man nicht irgendwo hinterlegen, dass sobald der wert "p1" (oder ähnlich) in eine Zelle eingetippt wird, sofort die anderen Zellen (je nach Dauer) mitmarkiert werden?
Beispiel:
Ich tippe in Zelle B22 den Wert "p3" ein, dann färbt sich die Zelle bisher nur blau.
Mein Wunsch: die Zellen B22 - B27 färben sich blau.
Geht das?
Lieben Dank.
https://www.herber.de/bbs/user/98166.xlsx

Bild

Betrifft: AW: Zellen Wertbedingt ergänzen?
von: Klexy
Geschrieben am: 12.06.2015 16:51:37
Du hast in der bedingten Formatierung "Nur Zellen formatieren, die enthalten" ausgewählt.
Du musst erst die Zelle B18 (das obere linke Eck deines Geltungsbereichs) auswählen
Dann in der bedingten Formatierung "Formel zur Ermittlung..." auswählen
Und dort folgendes reinschreiben:
=$B18="p3"

Bild

Betrifft: bei bedingten Formatierungen in Excel ab XL2007 ..
von: der neopa C
Geschrieben am: 12.06.2015 17:30:22
Hallo Ralf,
... nicht mit Zell-Kopie gearbeitet werden, sondern nur mit Werte einfügen oder Werte kopieren, weil alles andere schnell zum "Chaos" führen kann.
Lösche in Deiner jetzigen Datei zunächst alle Deine bedingten Formatierungen.

Dann markiere B18:Y148 und aktiviere die bedingten Formatierung und definiere die 4 Bedingungen mit "Formel zur Ermittlung ..." nacheinander neu:

1. =ZÄHLENWENN(B17:B18;"P1")>0 mit grüne
2. =ZÄHLENWENN(B16:B18;"P2")>0 mit gelb 
3. =ZÄHLENWENN(B13:B18;"P3")>0 mit blau 
4. =ZÄHLENWENN(B9:B18;"P2")>0 mit rot
Nun solltest Du noch mindestens den Zellen eine Datengültigkeit (Liste: P1;P2;P3;P4) zuweisen. Korrekter wäre es noch mittels einer Formel "Zeit-"-Überschneidungen zu verhindern. Aber das ist eine zweite Baustelle.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: bei bedingten Formatierungen in Excel ab XL2007 ..
von: Ralf
Geschrieben am: 17.06.2015 08:38:12
Hallo Werner,
danke, aber das funktioniert nicht.
Ich habe deine Schritte befolgt, aber wenn ich jetzt etwas eintrage, verändert sich nichts.
Anbei noch mal die editierte Datei.
Gruß
Ralf

Bild

Betrifft: AW: bei bedingten Formatierungen in Excel ab XL2007 ..
von: Ralf
Geschrieben am: 17.06.2015 09:29:51
https://www.herber.de/bbs/user/98259.xlsx

Bild

Betrifft: nein, hast Du leider nicht ...
von: der neopa C
Geschrieben am: 17.06.2015 17:19:49
Hallo Ralf,
... ich schrieb: "...Dann markiere B18:Y148 und aktiviere die bedingten Formatierung und definiere die 4 Bedingungen mit "Formel zur Ermittlung ..." nacheinander neu:"

Nun hast Du dazu in Deiner neuen Datei u.a. die Zeilenstruktur geändert.
Deshalb muss jetzt: markiere B10:Y140

1. =ZÄHLENWENN(B9:B10;"P1")>0 mit grün
2. =ZÄHLENWENN(B8:B10;"P2")>0 mit gelb 
3. =ZÄHLENWENN(B5:B10;"P3")>0 mit blau 
4. =ZÄHLENWENN(B1:B10;"P4")>0 mit rot
zuweisen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nein, hast Du leider nicht ...
von: Ralf
Geschrieben am: 22.06.2015 12:13:09
Hallo Werner,
top! Das funktioniert wunderbar. Danke dafür!
Gruß
Ralf

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellen Wertbedingt ergänzen?"