Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn 0 dann löschen | Herbers Excel-Forum


Betrifft: Wenn 0 dann löschen von: Ralf
Geschrieben am: 20.12.2009 11:24:17

Hallo und eien schönen 4 adv.
ich habe da mal ein anliegen und zwar habe ich eine Formel z.B in F 17
=E17-(B16<6)*(B16>1)*RegelMoDo-(B16=6)*RegelFr
Kann man die auch noch so ummodelieren, dass wenn in D 17 = 0 Dann inhalt in E und F 17 löschen also das die Zellen leer sind

  

Betrifft: ganau mit: (Wenn;Dann) von: Matthias L
Geschrieben am: 20.12.2009 11:39:13

Hallo

Besser wäre wenn man wüßte was in den relavanten Zellen steht!

Formel in E17 und F17
=WENN(D17=0;E17-(B16<6)*(B16>1)*RegelMoDo-(B16=6)*RegelFr;"")

Ich weiß allerdings nicht, ob ich es richtig verstanden habe.

Gruß Matthias


  

Betrifft: Korrektur von: Matthias L
Geschrieben am: 20.12.2009 11:47:49

Hallo

Sorry, die Formel kannst Du nur in F17 anwenden, sonst bekommst Du einen Zirkelbezugsfehler.
Besser, Du zeigst hier mehr von Deinem Konstrukt.

Gruß Matthias


  

Betrifft: AW: ganau mit: (Wenn;Dann) von: Ralf
Geschrieben am: 20.12.2009 11:51:12

sorry war wohl nicht ganz ausreichend erklärt also ich versuche es mal
Ich versuche mir gerade einen Stundenzettel zu erstellen also in D 16 17 18 werden die einzelnen Stunden eingetragen in E 17 ist Die summe D16 bis D 18 eingetragen also gesamte Stunden an dem Tag.
in F 17 ist dann die Formel =E17-(B16<6)*(B16>1)*RegelMoDo-(B16=6)*RegelFr eingetragen um die überstunden zu errechnen aber jetzt ist es so wenn Die arbeitnehmer Krank oder Urlaub eintragen rechnet er dann auch überstunden oder minusstunden aus deshalb suche ich ne formel wenn D 17 = 0 dann formel in F 17 nicht anwenden

vielleicht ist es so besser zu verstehen

gruß Ralf


  

Betrifft: zu unklar! von: Matthias L
Geschrieben am: 20.12.2009 11:59:16

Hallo Ralf

Welche Zelle ist RegelMoDo und was steht da drinn?
Jetzt kommen noch Überstunden Krank und Urlaub dazu.

Besser Du stellst hier ein Beispiel mit mehr Erklärung zur Verfügung

Gruß Matthias


  

Betrifft: AW: zu unklar! von: Ralf
Geschrieben am: 20.12.2009 12:02:18

Oh mist habe ausversehen ein neues Thema in der Liste eingebaut sollte eigentlich in dieser Liste mit rein aber hier die ganze Datei vielleicht hilft es ja weiter

https://www.herber.de/bbs/user/66714.xls


  

Betrifft: Versuch von: Matthias L
Geschrieben am: 20.12.2009 12:08:27

Hallo


in E17

=WENN(D17=0;"";D16+D17+D18)
in D17
=WENN(D17=0;"";E17-(B16<6)*(B16>1)*RegelMoDo-(B16=6)*RegelFr)
Das sollte es schon gewesen sein.

Gruß Matthias


  

Betrifft: AW: Versuch von: Ralf
Geschrieben am: 20.12.2009 12:25:34

Ja das ist schon fast das was ich brauche nur wenn ich die Formel einfüge verbindet er Dann zB die Zellen E17/E18 zu einer und dann schreibt er da in blau das ergebniss rein das gleiche passiert dann mit F17 F 18 geht das auch das die Formatierung so wie vorher bleibt ?

gruß Ralf


  

Betrifft: bei mir ist da nichts blau ... von: Matthias L
Geschrieben am: 20.12.2009 12:39:19

Hallo Ralf

Wenn ich nur die Formeln in die Zellen schreibe, verändere ich doch nichts am Zellformat.

Gruß Matthias


  

Betrifft: AW: Versuch von: Ralf
Geschrieben am: 20.12.2009 12:34:38

Hallo Das mit den zellen verbinden habe ich gelöst nur die Formatierung bereitet mir noch probleme
gibt es da was das die Formatierung so bleibt wie sie war also rahmen usw


  

Betrifft: jetzt ist alles klar von: Ralf
Geschrieben am: 20.12.2009 12:39:30

So habe das problem jetzt auch gelöst erst die Formeln einfügen dann die Formatierung so machen wie man sie haben möchte dann kann man es weiter kopieren man man man ab und zu hat man auch ne lange Leitung

aber Danke für deine schnelle hilfe

gruß Ralf


  

Betrifft: AW: Versuch von: Ralf
Geschrieben am: 20.12.2009 12:45:43

vielleicht hatte es damit zu tun das ich deine Formel kopiert habe und direkt eingefügt habe weiß aber auch nicht genau ob es damit zu tun hat bei mir war die schrift blau


Beiträge aus den Excel-Beispielen zum Thema "Wenn 0 dann löschen"