Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zelle füllen, wenn Artikel mehr als >= 50% negativ

Zelle füllen, wenn Artikel mehr als >= 50% negativ
19.10.2012 10:25:41
Marc
Hallo,
ich habe die Aufgabe Artikelbestände nachzuarbeiten, die einen Minusbestand über den kompletten Artikel von größer 50% haben. Ich habe dafür ein Beispiel erstellt, aus dem das hervorgeht. Der Artikel stellt sich zusammen aus der Artikelnummer (z.b. 1111) und der Farbe (z.B. 222). In einer weiteren Spalte habe ich die Bestände. Aufgabe ist es nun dann etwas (wonach ich filtern kann...) in eine weitere Spalte (hier Spalte C) zu schreiben, wenn insgesamt die Minusbestände des Artikels (also nicht der Farbe) mehr als oder gleich 50% sind. Beim Artikel 1111 sind es genau 50%, beim Artikel 2222 sind es weniger, weshalb dort keine Kennzeichnung erfolgt.
https://www.herber.de/bbs/user/82190.xlsx
Kann mir jemand helfen?
Ich habe schon viel versucht mit Summewenn und Zählewenn und so weiter, komme aber nicht weiter...
Danke und Gruß
Marc

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zelle füllen, wenn Artikel mehr als >= 50% negativ
19.10.2012 10:35:35
{Boris}
Hi Marc,
kapier ich nicht.
Beim Artikel 1111 sind es genau 50%, beim Artikel 2222 sind es weniger, weshalb dort keine Kennzeichnung erfolgt.
Kannst Du bitte mal Deine Rechnung dafür aufzeigen?
VG, Boris

AW: Zelle füllen, wenn Artikel mehr als >= 50% negativ
19.10.2012 10:42:35
Marc
Hallo Boris,
also, der Artikel 1111 (in insgesamt 4 verschiedenen Farben) hat diese 4 Einträge (A2-A5). Zwei dieser Einträge sind vom Bestand her im Minus (1111-333 und 1111-444).
Zwei Einträge von vieren sind 50%, also muss der Artikel markiert werden.
Beim Artikel 2222 haben wir 7 Einträge, wovon 3 im Minus sind (2222-333, 2222-444, 2222-555), 3 von 7 sind keine 50%, deswegen muss dieser Artikel nicht markiert werden.
Lieben Gruß
Marc

Anzeige
AW: Zelle füllen, wenn Artikel mehr als >= 50% negativ
19.10.2012 10:56:32
{Boris}
Hi Marc,
habe versucht, es möglichst allgemein zu halten. Bedinung: Artikelnummer und Farbe werden IMMER von einem Bindestrich (-) getrennt.
C2:
=WENN(SUMMENPRODUKT(((LINKS(A$2:A$100;FINDEN("-";A$2:A$100&"-")))=LINKS(A2;FINDEN("-";A2&"-"))) *(B$2:B$100=0,5;"Nacharbeiten";"")
und runterkopieren.
VG, Boris

AW: Zelle füllen, wenn Artikel mehr als >= 50% negativ
19.10.2012 11:35:02
Marc
Hi Boris,
ok, war ein schlechtes beispiel von mir... Ich bin soweit, dass ich nicht nach dem Beginn und Ende des Artikels (dieses "-" Zeichen) suchen muss, sondern, dass er direkt den Artikel nehmen kann.
Da ich leider Deine Formel nicht verstehe, könntest Du die nochmal bauen, ohne diese Suchfunktion? Dann verstehe ich vielleicht auch Deine Formel.
Danke und Gruß
Marc

Anzeige
AW: Zelle füllen, wenn Artikel mehr als >= 50% negativ
19.10.2012 13:30:44
{Boris}
Hi Marc,
aus der Hand:
In Spalte A steht nun die Artikelnummer und in Spalte B der Bestand.
Dann in C2 (und runterkopieren):
=WENN(SUMMENPRODUKT((A$2:A$100=A2)*(B$2:B$200=0,5;"Nacharbeiten";"")
VG; Boris

Bekomme ein #NV...
19.10.2012 13:39:32
Marc
:(

Tippfehler...
19.10.2012 13:45:01
{Boris}
Hi Marc,
das kommt davon, wenn man aus der Hand schreibt ;-)
Die "200" muss "100" lauten:
=WENN(SUMMENPRODUKT((A$2:A$100=A2)*(B$2:B$100=0,5; "Nacharbeiten";"")
VG, Boris

GROßARTIG!!! Danke!!
19.10.2012 13:53:50
Marc
o.T.

311 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige