Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

wenn>0 dann Teil

wenn>0 dann Teil
Marcus
Hallo,
ich brauche noch eine Hilfestellung. Ich brauche eine wennFormel :
In B1 (als Beispiel) soll ein Teilergebnis von A1 rein, aber nur, wenn es größer als 0 ist.
Wenn A1 größer als 0 dann brauche ich aus A1 das 5-8 Zeichen als Teilergebnis Verkettet mit "AG".
Ist das machbar ?
Für jeden Hinweis dankbar.
AW: wenn>0 dann Teil
07.09.2011 09:21:57
hary
hallo Marcus
hier mit laengenpruefung. Meinst Du so? Tabellenblattname: Tabelle1
 

A

B

1

123456789

AG 567

2

1234567

 

3

1234567890

AG 567

4

0

 


Benutzte Formeln:
B1: =WENN(UND(LÄNGE(A1)>=8;A1>0);"AG "&TEIL(A1;5;3);"")
B2: =WENN(UND(LÄNGE(A2)>=8;A2>0);"AG "&TEIL(A2;5;3);"")
B3: =WENN(UND(LÄNGE(A3)>=8;A3>0);"AG "&TEIL(A3;5;3);"")
B4: =WENN(UND(LÄNGE(A4)>=8;A4>0);"AG "&TEIL(A4;5;3);"")
gruss hary
Anzeige
AW: wenn>0 dann Teil
07.09.2011 09:35:53
Marcus
Jawollo ! Danke Harry das passt ! Das hilft mir super weiter.
richtig formuliert ? wirklich Teilergebnis() ?
07.09.2011 09:26:48
Matthias
Hallo
Zitat
Wenn A1 größer als 0 dann brauche ich aus A1 das 5-8 Zeichen als Teilergebnis Verkettet mit "AG".
Ok. In A1 steht eine 2
Und jetzt? Was soll da das das 5-8 Zeichen ein ?
Ich verstehe nur "Bahnhof"
Ich weiß auch nicht was Du bei nur einer Zelle mit der Funktion Teilergebnis() rechnen willst.
Warum machst Du nicht ein konkretes Beispiel, in dem man sieht was wo steht
und was Du wo und warum erwartest.
Gruß Matthias
AW: richtig formuliert ? wirklich Teilergebnis() ?
07.09.2011 09:32:34
Marcus
Moin Matthias,
jau da hast Du recht. Mein Fehler. Hoffe so ist es deutlicher :
Also in A1 steht immer (oder ähnlich; Firmencode; int. ID) :
GHJ,992 (in diesem Fall brauche ich die 992 also verkettet mit AG (Ergebnis 992 AG)
Rechnen will ich gar nichts, ich muss nur einige Tausend Zeilen in eine csv prügeln und diese dann weiterverarbeiten.
Anzeige
also immer die Zahl rechts vom Komma ? oT
07.09.2011 09:35:02
Matthias
AW: also immer die Zahl rechts vom Komma ? oT
07.09.2011 09:36:37
Marcus
Jau, aber die Lösung von Harry hat mir schon geholfen. Danke Matthias !
also wenn ich schonmal angefangen habe ...
07.09.2011 09:44:28
Matthias
Hallo
... kann ich es auch posten
Ich habs dann so gelöst:
Tabelle1

 AB
1interne FirmenIDVerkettet
2GH,992992 AG
3KLO,659659 AG
4F,12341234 AG

Formeln der Tabelle
ZelleFormel
B2=TEIL(A2;FINDEN(",";A2)+1;LÄNGE(A2))&" AG"
B3=TEIL(A3;FINDEN(",";A3)+1;LÄNGE(A3))&" AG"
B4=TEIL(A4;FINDEN(",";A4)+1;LÄNGE(A4))&" AG"


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige
AW: also immer die Zahl rechts vom Komma ? oT
07.09.2011 09:36:37
Marcus
Jau, aber die Lösung von Harry hat mir schon geholfen. Danke Matthias !
=RECHTS(A1;LÄNGE(A1)-FINDEN(",";A1))&" AG"
07.09.2011 09:39:34
hary
Hallo
dann so.
Tabellenblattname: Tabelle1
 

A

B

6

GHJ,992

992 AG


Benutzte Formeln:
B6: =RECHTS(A6;LÄNGE(A6)-FINDEN(",";A6))&" AG"
gruss hary
Anzeige
AW: =RECHTS(A1;LÄNGE(A1)-FINDEN(",";A1))&" AG"
07.09.2011 09:48:21
Marcus
Noch eine Frage :
wenn ich die Firmel auf ca. 2000 Zeilen runterziehe, und hinterher einen Ausdruck brauche, haut er mir ca. 100 Seiten leer raus, wenn ich mal nur 200 Inhalte habe. Kann ich einen Ausdruck beschränken auf "Inhalte" ?
AW: autofilter?
07.09.2011 10:10:32
hary
Hallo
und wenn Du Autofilter(nichtleere) nach SpalteB nimmst?
gruss hary
AW: autofilter?
07.09.2011 10:36:36
Marcus
Hi,
das könnte zwar hinhauen, aber er soll auch drucken wenn B1 leer ist und aber in anderen spalten/zeilen noch was steht. Nur die Zeilen wo gar nichts (ausser der Formel in B eben) sollen nicht gedruckt werden. Eigentlich also "nur inhalte" drucken. Aber wie ?!
AW: hilfsspalte und autofilter
07.09.2011 15:46:36
hary
Hallo Marcus
wenn machbar, gehts am schnellsten mit Hilfsspalte. Autofilter SpalteA .
Tabelle1
 ABCDEFG
11a         
21  a  a  a
31        a 
40           
51    a     
61      a   
71        a 
80           

verwendete Formeln
Zelle Formel Bereich
A1 =WENN(ANZAHLLEEREZELLEN(B1:G1)=6;0;1) 
A2 =WENN(ANZAHLLEEREZELLEN(B2:G2)=6;0;1) 
A3 =WENN(ANZAHLLEEREZELLEN(B3:G3)=6;0;1) 
A4 =WENN(ANZAHLLEEREZELLEN(B4:G4)=6;0;1) 
C4 =WENN(I4="";"";I4) 
A5 =WENN(ANZAHLLEEREZELLEN(B5:G5)=6;0;1) 
A6 =WENN(ANZAHLLEEREZELLEN(B6:G6)=6;0;1) 
A7 =WENN(ANZAHLLEEREZELLEN(B7:G7)=6;0;1) 
A8 =WENN(ANZAHLLEEREZELLEN(B8:G8)=6;0;1) 

Tabellendarstellung in Foren Version 5.30


gruss hary
Anzeige

346 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige