WENN UND DANN SONST

Bild

Betrifft: WENN UND DANN SONST
von: Alexander Benz
Geschrieben am: 11.06.2015 09:00:12

Hallo zusammen,
ich habe folgende Frage :
Ich benötige für eine Tabelle welche die zu erwartende Umschlagsdauer ermittelt eine Funktion die folgendes darstellen kann :
Aktuell ist die Formel so : =WENNFEHLER(RUNDEN(1/(I2/A2);1);"")
Das führt dazu das wenn Versand : Bestand keinen Teiler hat das Feld Umschlagsdauer leer bleibt. Das istz im Falle "0 Bestand : 0 Versand" auch richtig.
Wenn aber "0 Versand : vorhandenen Bestand" soll die Formel darauf hinweisen in Form eines Textes - "Achtung kein Versand !"
Geht so etwas überhaupt ?
Mein Ansatz wäre eine WENN UND DANN SONST Formel.
Hat hierzu jemand eine Idee ?
Für eure Hilfe vielen Dank
Anbei ein Testfile - Die Originaldatei ist zu groß.
https://www.herber.de/bbs/user/98138.xlsx
Grüße
Alex

Bild

Betrifft: AW: WENN UND DANN SONST
von: Kenny
Geschrieben am: 11.06.2015 09:12:16
Hi Alex,


=WENNFEHLER(WENN(ZS(4)>0;RUNDEN(1/(ZS(4)/ZS(-4));1);"Achtung kein Versand!");"")
so?
Grüße

Bild

Betrifft: AW: WENN UND DANN SONST
von: Alexander Benz
Geschrieben am: 11.06.2015 12:25:24
Hallo ,
vielen Dank für die Formel. Ich denke das könnte so klappen.
Aber wie bekomme ich den Zusammenhang zu meiner Formel :
Meine : WENNFEHLER(RUNDEN(1/(BU7/BL7);1);"") und Deine : WENNFEHLER(WENN(ZS(4)>0;RUNDEN(1/(ZS(4)/ZS(-4));1);"Achtung kein Versand!");"")
... das ist mir nicht ganz klar.
Grüße
Alex

Bild

Betrifft: AW: WENN UND DANN SONST
von: Alexander Benz
Geschrieben am: 12.06.2015 07:09:54
Hat hier jemand eine Idee ?
Meine Formel lautet : WENNFEHLER(RUNDEN(1/(BU7/BL7);1);"") und gibt gibt den Wert 0 zurück, wenn BU7 0 ist und BL 7 0 ist - soweit auch richtig. Ich möchte zusätzlich die Außnahme einfügen, das ich "Achtung kein Versand!" angezeigt bekomme, wenn : BU7 = 0 aber BL7 größer 0 ist.
Danke für euere Unterstützung
Grüße
Alex


Bild

Betrifft: AW: WENN UND DANN SONST
von: Kenny
Geschrieben am: 12.06.2015 08:43:59
Hi,
Sorry hatte meinen Bezug anders eingestellt.
Meinst du so?:


=WENNFEHLER(WENN(J2>0;RUNDEN(1/(I2/A2);1);"Achtung kein Versand!");"")
Ansonnsten nochmal melden. Weiß nicht genau, was du jetzt mit BU7 und BL7 meinst. In deiner Beispieldatei sind es glaub andere Zellen.
Grüße Kenny

Bild

Betrifft: AW: WENN UND DANN SONST
von: Alexander Benz
Geschrieben am: 12.06.2015 09:47:30
Hallo Kenny,
so wie Du die Formel geschrieben hast wird "Kein Versand" angezeigt wenn J2 0 ist. Ich benötige die Aussage "Kein Versand" wenn Spalte J ist = 0 aber Spalte A ist größer 0.
Ich habe im Beispiel 2 Kommentare eingefügt :-)
https://www.herber.de/bbs/user/98161.xlsx
Danke für die Unterstützung
Gruß
Alex

Bild

Betrifft: AW: WENN UND DANN SONST
von: Kenny
Geschrieben am: 12.06.2015 12:56:48
Ich hoffe so passt es:


=WENNFEHLER(WENN(UND(I2=0;A2>0);"Achtung kein Versand!";RUNDEN(1/(I2/A2);1));"")
Liebe Grüße

Bild

Betrifft: AW: WENN UND DANN SONST
von: Alexander Benz
Geschrieben am: 12.06.2015 14:09:30
Hallo Kenny,
ja, genau das habe ich gesucht :-))))) . Vielen Dank und ein schönes Wochenende :-)

Bild

Betrifft: AW: WENN UND DANN SONST
von: Kenny
Geschrieben am: 12.06.2015 14:12:54
Gerne!!! Danke dir auch :)

 Bild

Beiträge aus den Excel-Beispielen zum Thema "formel string zerlegen"