Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS mit 3 Vergleichswerten

Betrifft: SVERWEIS mit 3 Vergleichswerten von: Reservist
Geschrieben am: 21.08.2004 12:32:08

Hallo,

heut` mal noch eine 2-te Frage, die mein bisheriges
"Geformele" stark reduzieren könnte.

Mit einfachen SVERWEIS-Formeln mit einem VERGLEICH komme ich zurecht.
Ich benötige aber eine Formel, die 3 Vergleichswerte hat.
Geht dies?
Wenn ja und wer sich damit auskennt bitte mal ansehen:

https://www.herber.de/bbs/user/9905.xls

Vielen Dank
Gruß Thorsten

  


Betrifft: AW: SVERWEIS mit 3 Vergleichswerten von: andreas e
Geschrieben am: 21.08.2004 13:16:52

hallo reservist thorsten,

sieh dir dazu mal excelformeln.de an

speziell vielleicht

http://excelformeln.de/formeln.html?welcher=33

gruß
andreas e
http://www.skripteundaufgaben.de


  


Betrifft: Nummer zu hoch von: Reservist
Geschrieben am: 21.08.2004 13:37:57

Hallo Andres,

danke für Antwort/Hinweis. Probiere noch ein biss`l.
Hatte schon vermutet, dass hier Array-Formeln zum Einsatz kommen.
Ist wohl `ne Nummer zu hoch für mich.

Gruß Thorsten


  


Betrifft: AW: Nummer zu hoch von: Reservist
Geschrieben am: 21.08.2004 14:08:32

Das bekomme ich nicht hin.


  


Betrifft: AW: SVERWEIS mit 3 Vergleichswerten von: Josef B
Geschrieben am: 21.08.2004 15:32:48

Hallo Thorsten


Das geht in deinem Beispiel mit folgender Formel:
=SVERWEIS(E5;B10:N20;VERGLEICH(E2;C7:N7;0)+VERGLEICH(E3;C8:N8;0)-1+VERGLEICH(E4;C9:N9;0);0)

Gruss Josef


  


Betrifft: @ Josef von: Reservist
Geschrieben am: 21.08.2004 17:08:41

Hallo Josef,

Tausend Dank, dass ist doch mal ne Formel die nicht nur funktioniert,
sondern die ich auch noch im Kopf behalten kann.
Da war ich mit meinen ersten Versuch nahe dran. Danach habe mich
ohne geringsten Erfolg mit Formel beschäftigt, die ich eh nicht verstehe.
Ich weis nur nicht, was bewirkt die letzte ";0" in den Vergleichen?

Also nochmal vielen Dank und
Gruß Thorsten


  


Betrifft: Danke für die Ruckmeldung und.... von: Josef B
Geschrieben am: 21.08.2004 17:25:50

Hallo Thorsten

....die letzte Null gehöhrt zum SVERWEIS, wozu diese Null ist, weisst du sicher.

Gruss Josef


  


Betrifft: @Josef - bitte nochmal - muss es jetzt begreifen von: Reservist
Geschrieben am: 21.08.2004 18:19:42

Hallo Josef,

Excel zeigt mir zwar an "Vergleichstyp" aber ich weis es trotzdem nicht.
Jetzt möchte ich es gerne wissen.
Bisher habe ich immer mit einfachen "Kreuzvergleichen" gearbeitet.
Um mal beim alten Beispiel zu bleiben, z.B.

=SVERWEIS(E5;B10:D20;VERGLEICH(E4;B9:D9))

und das hat bei dieser einfachen Variante immer funktioniert.
Warum brauch sie den Vergleichstyp nicht?

Gruß Thorsten

PS. Gibt es gute Lektüre wo man solche Formeln und aufwärts
verständlich erlernen kann. Zwar bekomme ich in diesem
gutem Forum immer Antwort und meist gute Lösungen, die im
Moment mein Problem beheben. Nur wenn man sie nicht versteht
ist es schlecht. Wenn das nächstemal die Konstulation ein
klein wenig anders ist, muss man wieder fragen.


  


Betrifft: AW: @Josef - bitte nochmal - muss es jetzt begreifen von: Josef B
Geschrieben am: 21.08.2004 19:30:38

Hallo Thorsten

Den Vergleichstyp braucht es nicht unbedingt, wenn die Matrix, in der gesucht wird, aufsteigend sortiert ist. Wenn SVERWEIS das Suchkriterium nicht finden kann, und Bereich_Verweis ist nicht angegeben oder "WAHR" oder 1, wird der größte Wert verwendet, der kleiner oder gleich Suchkriterium ist.
Man bemerkt dann allerdings auch nicht, wenn ein Suchkriterium in der Matrix nicht vorhanden ist, weil dann eben nach dem nächst kleineren Wert gesucht wird.
In deinem Fall würde ich diese Nullen in der Formel belassen, vor allem beim Vergleich der den Typ absucht, denn Typ 1 Typ 2 Typ 3 bis Typ 15 ist eben nicht aufsteigend sortiert, was zu Fehlern führen kann.

Solche Formeln und Aufwärts kannst du meiner Meinung nach nur in einem Excel-Forum wie zum Beispiel diesem hier erlernen. Versuche da einfach vorhandene Lösungen nachzuvollziehen oder deinem Können entsprechend selber zu entwickeln.

Gruss Josef


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS mit 3 Vergleichswerten"