Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
672to676
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
672to676
672to676
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Sverweis auf Tabellenblatt mit doppelten Einträgen

Sverweis auf Tabellenblatt mit doppelten Einträgen
29.09.2005 16:59:06
kim
hallo leute,
hab da mal n problem....
möchte mit hilfe eines sverweises einen wert aus einem
tabellenblatt ziehen, allerdings ist das suchkriterium
in dem zu durchsuchenden bereich nicht eindeutig (kommt teils 2 - 3 x vor).
logischer weise liefert excel nv# zurück da es natürlich mehrere ergebnisse
findet....
habt ihr da eine idee wie ich das gebacken kriege?
vielen dank für eure hilfe im voraus
gruss
kim

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Sverweis auf Tabellenblatt mit doppelten Einträgen
29.09.2005 17:03:41
HermannZ
Hallo Kim;
schau eimal hier;
www.excelformeln.de/formeln.html?welcher=28
Gruß hermannZ
AW: Sverweis auf Tabellenblatt mit doppelten Eintr
29.09.2005 17:12:18
Erich
Hallo Kim,
SVerweis findet das Suchkriterium auch, wenn es is der Matrix mehrfach vorkommt.
Beispiel:
 
 ABCDE
1KeyWert Suchkrit.SVerweis
2a11 c12
3c12 a11
4g13   
5e14   
6a15   
7d16   
Formeln der Tabelle
E2 : =SVERWEIS(D2;$A$2:$B$7;2;FALSCH)
E3 : =SVERWEIS(D3;$A$2:$B$7;2;FALSCH)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Dass bei dir #NV als Wert kommt, müsste einen anderen Grund haben.
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: Sverweis auf Tabellenblatt mit doppelten Eintr
30.09.2005 11:06:03
kim
vielen dank für die schnelle hilfe leute.
aber leider scheine ich nicht fähig zu sein das
zu lösen... hmmm...
ich hab mal einen auszug der datei ins forum gestellt evtl wird
ersichtlich wo der fehler liegt.
https://www.herber.de/bbs/user/27076.xls
im zweiten blatt soll anhand der artikelnummer die artikelbezeichnung
aus dem ersten blatt gezogen werden.
ich sag schon mal wieder vielen dank im voraus
gruss
kim
AW: Sverweis auf Tabellenblatt mit doppelten Eintr
30.09.2005 13:22:45
jens
Hallo kim
da deine suchkriterium in der tabelle bestandsaufnahme nicht in der ersten spalte ist kann excel auch nichts finden.
sverweis sucht in der matrix immer von der ersten spalte nach rechts.
setzt die Atikelnummer mal in Spalte A dann bekommst du auch ein ergebnis
Gruß
Jens
Anzeige
AW: Sverweis auf Tabellenblatt mit doppelten Eintr
30.09.2005 14:13:55
Erich
Hallo Kim,
Jens hat dir ja schon geschrieben dass SVerweis nicht geht - weil die Spalte mit dem Schlüssel in der Bestandsaufnahme nicht links von der Wertspalte liegt.
Mit VERWEIS gehts aber:
 
 AB
1Artikel-
nummer
Artikel-
bezeichnung
2164735Curl Stange
3173634Vito XL Crosstrainer
Formeln der Tabelle
B2 : =VERWEIS(A2;'Bestandsaufnahme 14.09.05'!$D$2:$D$11;'Bestandsaufnahme 14.09.05'!$E$2:$E$11)
B3 : =VERWEIS(A3;'Bestandsaufnahme 14.09.05'!$D$2:$D$11;'Bestandsaufnahme 14.09.05'!$E$2:$E$11)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige

326 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige