Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1572to1576
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

24h Mittelwerte aus anderer Tabelle

24h Mittelwerte aus anderer Tabelle
17.08.2017 08:46:11
Reiner
Hallo Forum,
ich muss aus einer Quelltabelle (=Tabelle1), in der über einen längeren Zeitraum stündlich mitgeschriebene Messwerte aufgeführt sind 24h-Mittelwerte extrahieren und in eine neue Tabelle (=Tabelle2) schreiben.
Dafür habe ich in Tabelle2 die Datumsangaben in die erste Spalte geschrieben und wollte nun in der zweiten Spalte einen Mittelwert berechnen. Dafür wollte ich mit SVERWEIS den ersten Wert des Tages plus die 23 folgenden mitteln. Das ganze muss dann auf viele Datumsangaben in Spalte1, Tabelle2 übertragbar sein. Funktioniert hat das nicht.
=(SVERWEIS(A4&" 00:00:00";'Tabelle1'!A9:O41;15;FALSCH)+SVERWEIS(A4&" 01:00:00";'Tabelle1'!A9:O4100; 15;FALSCH)+...+SVERWEIS(A4&" 23:00:00";'Tabelle1'!A9:O4100;15;FALSCH)) /24
bringt mit einen NV-Fehler.
Ich bin mir im klaren, dass das ein wenig eleganter Lösungsansatz ist und bitte um milde. Besten Dank.
zur Veranschaulichung meine Tabellen:
Tabelle1
Datum Messwert
01.01.2017 00:00:00 1
01.01.2017 01:00:00 2
01.01.2017 02:00:00 3
01.01.2017 03:00:00 4
...
01.01.2017 23:00:00 24
02.01.2017 00:00:00 25
02.01.2017 01:00:00 26
...
Tabelle2
Datum 24h-Mittelwert
01.01.2017 12,5
02.01.2017 36,5
...

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: 24h Mittelwerte aus anderer Tabelle
17.08.2017 08:47:11
SF
Hola,
eine Beispieldatei wäre hilfreich.
Gruß,
steve1da
mit INDEX-Spreizung
17.08.2017 09:01:51
lupo1
Stündlich heißt fixe 24mal pro Tag, ohne Ausfall und Zusätze, ab Zeile 2 wegen Überschrift.

=MITTELWERT(INDEX(B:B;ZEILE(A1)*24-23):INDEX(B:B;ZEILE(A1)*24))
runterkopieren
=INDEX(B:B;ZEILE(A1)*24-23) holt Dir das Datum dazu, obwohl man das natürlich leichter einfach mit =Vorgängerdatum+1 runterziehen kann.
da schreibe ich noch Zeile 2 und dann ...
17.08.2017 09:03:08
lupo1
... vergesse ich deren Berücksichtigung:
=MITTELWERT(INDEX(B:B;ZEILE(A1)*24-22):INDEX(B:B;ZEILE(A1)*24+1))
AW: mit INDEX-Spreizung
17.08.2017 09:06:30
Reiner
Hier eine Beispieldatei: https://www.herber.de/bbs/user/115534.xlsx
Danke lupo1 für den Vorschlage, werde ich gleich testen.
Es ist leider immer wieder so, dass es wegen Ausfällen unvollständige Datensätze gibt. Kann ich irgendwie einen Datenumsabgleich in die Abfrage einbauen?
Anzeige
AW: mit INDEX-Spreizung
17.08.2017 09:24:55
Robert
Hallo Reiner,
eine Möglichkeit ohne die Index-Funktion wäre folgende (für Zelle B4 Deiner Beispieldatei):
=SUMMEWENNS(Tabelle1!B:B;Tabelle1!A:A;">="&A4;Tabelle1!A:A;"="&A4;Tabelle1!A:A;"

Gruß
Robert
AW: dann mal wieder eine Matrixformel ...
17.08.2017 09:25:54
...
Hallo reiner,
... so: {=MITTELWERT(WENN(KÜRZEN(Tabelle1!A$4:A$9999;0)=A4;Tabelle1!B$4:B$9999))}
Umrandende { } nicht miteingeben,sondern Formel mit STRG+SHIFT+RETURN abschließen!
Gruß Werner
.. , - ...
AW: am einfachstes & schnellsten ist PIVOTausw ...
17.08.2017 09:32:43
...
Hallo Reiner,
... und noch noch dazu am flexibelsten.
Dazu musst Du lediglich das Feld "Datum" nach Tage gruppieren.
Gruß Werner
.. , - ...
Anzeige
mit 2 Summenprodukt
17.08.2017 09:40:28
WF
Hi,
in B4:
=SUMMENPRODUKT((GANZZAHL(Tabelle1!A$4:A$999)=A4)*(Tabelle1!B$4:B$999)) /SUMMENPRODUKT((GANZZAHL(Tabelle1!A$4:A$999)=A4)*1)
runterkopieren
WF
AW: mit 2 Summenprodukt
17.08.2017 09:50:13
Reiner
Danke für die vielen eleganten Lösungen. Sie funktionieren - jetzt muss ich sie nur noch verstehen. Ich verschwinde dann mal in den Tutorials zu Matrix, index, summenprodukt und co.
Dafür gibt es MITTELWERTWENNS
17.08.2017 10:30:04
Robert
Hallo,
nach etwas suchen habe ich die MITTELWERTWENNS-Funktion gefunden, die müsste doch genau dafür gedacht sein:
=MITTELWERTWENNS(Tabelle1!B:B;Tabelle1!A:A;">="&A4;Tabelle1!A:A;"
Gruß
Robert
Anzeige
AW: 24h Mittelwerte aus anderer Tabelle
17.08.2017 10:47:51
Cardexperte
Hallo
warum nicht mittels Filter (Autofilter reicht erst mal schon) und =Teilergebnis(101;"Bereich"), dies kann man auch in einem Makro so gestalten, dass mittels Auswahl (Datum) die Werte auch in die andere Tabelle geschrieben werden. Dies klappt auch, falls Daten fehlen, möglich ist auch gleich mittels Spezialfilter das zu machen.
Gruss WS

324 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige