Bedingte Formatierung über mehrere Zellen

Bild

Betrifft: Bedingte Formatierung über mehrere Zellen
von: Alexander
Geschrieben am: 30.05.2015 16:06:51

Hallo liebe Excel Gemeinde,
Ich habe eine Bedingte Formatierung über einen Bereich erstellt.
Leider wird diese nur auf die erste Zelle des Bereiches angewendet.
Könnt ihr mir sagen woran das liegen kann?
Januar

 ABCDEFGHIJ
701Do        

Formeln der Tabelle
ZelleFormel
A7=TEXT(DATUM(C2;MONAT(1&B2); 1); "TT")
B7=WENN(A7="";"";TEXT(DATUM($C$2;MONAT(1&$B$2); A7*1); "TTT"))

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
A72. / Formel ist =ODER(B7="Sa";B7="So")Abc
B71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
B72. / Formel ist =ODER(B7="Sa";B7="So")Abc
C71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
C72. / Formel ist =ODER(B7="Sa";B7="So")Abc
D71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
D72. / Formel ist =ODER(B7="Sa";B7="So")Abc
E71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
E72. / Formel ist =ODER(B7="Sa";B7="So")Abc
F71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
F72. / Formel ist =ODER(B7="Sa";B7="So")Abc
G71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
G72. / Formel ist =ODER(B7="Sa";B7="So")Abc
H71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
H72. / Formel ist =ODER(B7="Sa";B7="So")Abc
I71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
I72. / Formel ist =ODER(B7="Sa";B7="So")Abc
J71. / Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);A7*1))=1Abc
J72. / Formel ist =ODER(B7="Sa";B7="So")Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Hier noch die Beispieldatei
https://www.herber.de/bbs/user/97940.xlsx
Gruß
Alex

Bild

Betrifft: AW: Bedingte Formatierung über mehrere Zellen
von: Hajo_Zi
Geschrieben am: 30.05.2015 16:16:41
Du hast es vorgegeben. Wird angewendet auf =$A$7:$J$7 und absolut Bezüge fehlen.

Januar

 ABCDEFGHIJ
701Do        
802Fr        
903Sa        
1004So        
1105Mo        
1206Di        

verwendete Formeln
Zelle Formel Bereich N/A
A7=TEXT(DATUM(C2;MONAT(1&B2);1);"TT")  
A8:A12=WENN(A7="";"";WENN(MONAT(A7+1)<>MONAT(A7);"";TEXT(A7+1;"TT")))  
B7:B12=WENN(A7="";"";TEXT(DATUM($C$2;MONAT(1&$B$2);A7*1);"TTT"))  

definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
Feiertage=Feiertage!$C$2:$C$14 =Feiertage!R2C3:R14C3

Bedingte Formatierung Haupttabelle 1  
Wird angewendet auf   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$A$7:$J$3701.Bed.: Formel ist =ZÄHLENWENN(Feiertage;DATUM($C$2;MONAT(1&$B$2);$A7*1))=1  11851260         2A7:J37
$A$7:$J$3702.Bed.: Formel ist =ODER($B7="Sa";$B7="So")  14277081         2A7:J37
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich    
Wird angewendet auf   Nr. Bed.  Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$A$7:$J$3701.Bed.   Falsch          2A7:J37
$A$7:$J$3702.Bed.   Falsch          2A7:J37
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.04 einschl. 64 Bit




Bild

Betrifft: Danke jetzt gehts. Gruß Alex owT
von: Alexander
Geschrieben am: 30.05.2015 16:33:37


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bedingte Formatierung über mehrere Zellen"