Excel Formel auf weitere Zeilen anwenden

Bild

Betrifft: Excel Formel auf weitere Zeilen anwenden
von: hayii it
Geschrieben am: 31.07.2015 14:23:58

Hallo,
ich habe ein Problem. Versuche es mal so detailliert wie möglich zu erklären:
1. Es existiert eine Excel Datei mit 2 Blättern.
2. Blatt 1 greift auf einzelne Zeilen Blatt 2 zu.
3. Grob sieht das Ganze so aus:
A227: =WENN('PB Attachment B'!B37>0;'PB Attachment B'!B37;" " )
A228: =A227
A229: =A228
A230: =A229
A231: =A230
A232: =A231
A233: =A232
A234: =A233
A235: =A234
~f~
Natürlich fangen die Formeln schon vorher an und zwar bei A2. Also von A2 bis A235 fortlaufend.
4. Nun mein Problem:
Ich möchte, dass ab A235 die Einträge weiterhin wiederholt (wie in obiger Reihenfolge) übernommen werden. D.h.:
~f~
A227: =WENN('PB Attachment B'!B37>0;'PB Attachment B'!B37;" " )
A228: =A227
A229: =A228
A230: =A229
A231: =A230
A232: =A231
A233: =A232
A234: =A233
A235: =A234
A227: =WENN('PB Attachment B'!B38>0;'PB Attachment B'!B38;" " )
A228: =A236
A229: =A237
A230: =A238
A231: =A239
A232: =A240
A233: =A241
A234: =A242
A235: =A243
Bisher wurde all das manuell eingetragen. Kann man das Ganze jetzt beispielsweise für ca. 19 000 Einträge erweitern?
Also dass am unteren Ende der Excel Datei der 19 000te Eintrag steht?
Es wäre so toll wenn mir einer helfen könnte. Danke :)

Bild

Betrifft: AW: Excel Formel auf weitere Zeilen anwenden
von: Rudi Maintaire
Geschrieben am: 31.07.2015 15:10:42
Hallo,

A
212
312
412
512
612
712
812
912
1012

ZelleFormel
A2=WENN(INDEX('PB Attachment B'!B:B;(ZEILE()-2)/9+12)>0;INDEX('PB Attachment B'!B:B;(ZEILE()-2)/9+12);"")
A3=A2
A4=A3
A5=A4
A6=A5
A7=A6
A8=A7
A9=A8
A10=A9

und alles nach unten kopieren.
Gruß
Rudi

Bild

Betrifft: AW: Excel Formel auf weitere Zeilen anwenden
von: Hayi it
Geschrieben am: 31.07.2015 15:58:20
Hallo Rudi,
woow super vielen dank!! Das funktioniert einwandfrei!!
Ich hab noch ein letztes Problem.
Neben der Spalte A sind noch weitere Spalten mit Formeln belegt. Ich zeige dir mal wie das aussieht:
B2: =WENN(A2<>" ";"X1F_ENVIRON_DATA";" ")
C2: =WENN(B2="X1F_ENVIRON_DATA";"Umweltbezogene Verpackungsdaten";" ")
D2: =WENN(A2<>" ";"X1F_AAA0071";" ")
E2: =WENN(D2="X1F_AAA0071";"Papier,Pappe,Karton";" ")
G2: =WENN('PB-002 Attachment B'!D8>0;'PB Attachment B'!D8;" ")
K2: =WENN(A2<>" ";"NUM";" ")
L2: =WENN(K2="NUM";6;" ")
M2: =WENN(K2="NUM";2;" ")
P2: =WENN(K2="NUM";"G";" ")
Diese Zeilen werden zwar fortlaufen nummeriert, jedoch zeigen die Zeilen keine Werte an. Also wenn ein Eintrach erfolgt??
Liebe Grüße
Hatice

Bild

Betrifft: AW: Excel Formel auf weitere Zeilen anwenden
von: AlexG
Geschrieben am: 01.08.2015 10:11:22
Hallo Hatice,
so wie das hier aussieht prüfst nicht nach leeren Zellen, sondern nach Zellen die ein Leerzeichen enthalten. Du darfst zwischen den "Gänzefüßchen" kein Leerzeichen eingeben.
Gruß
Alex

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel Formel auf weitere Zeilen anwenden"