Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
904to908
904to908
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Gleiche Werte in Zellen finden und ...

Gleiche Werte in Zellen finden und ...
16.09.2007 23:43:30
farnk
Hallo!
Ich habe ein Problem.
Ich habe eine Excel-Liste, in der viele Daten stehen.
Ein Tatensatz steht in einer Zeile, und ist in Spalte A bis M gegliedert, also eine normale Tabelle.
Sie hat ca 4000 Zeilen.
Jetzt zu meinem Problem.
Die Tabelle ist nach Spalte E sortiert, und jetzt möchte ich gerne, dass die gleichen Einträge gefunden werden, und in einem anderen Tabellenblatt wiedergegeben werden.
Also: Wenn in Spalte E nun z.B.
740
740
965
Apfel
Apfel
Birne
Birne
Birne
Essen5
Essen6
Saft
.... steht, dann sollte Excel mir in einem anderen Tabellenblatt folgendes wiedergeben:
2 740
2 Apfel
3 Birne
Falls das nicht geht, oder zu schwer ist, würde es mir auch helfen, wenn die doppelten Einträge einfach makiert werden.
Ich hoffe mir kann jemand helfen.
Ich habe schon mit Bedingter Formatierung und auch VBA herumexperimentiert, aber es hat nicht geklappt.
Vielen Dank schon mal.

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Gleiche Werte in Zellen finden und ...
17.09.2007 00:26:00
Jens
Hi
Bedingte Formatierung:
=ZÄHLENWENN(E:E;E1)>1 (Erster Eintrag in E1)
und herunterkopieren.
Gruß aus dem Sauerland
Jens

und noch 'n gedicht...
17.09.2007 10:09:49
jockel
hi farnk coke, hier noch eine variante. einmal werden alle werte aus der ersten tabelle (nur) einmal aufgeführt spalte A und die zweite möglichkeit gibt nur die mehrfach aufgetretenen werte aus der ersten tabelle aus:
Tabelle1
 A
1740
2740
3965
4Apfel
5Apfel
6Birne
7Birne
8Birne
9Essen5
10Essen6
11Saft
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Tabelle2
 ABCDE
1liste ohne dopplerAnzahl nur mehrfach auftretende werteAnzahl
2     
37402 7402
49651 Apfel2
5Apfel2 Birne3
6Birne3   
7Essen51   
8Essen61   
9Saft1   
Formeln der Tabelle
A3 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)))<ZEILE(A1); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE($1:$100)); Tabelle1!A$1:A$100)=1;ZEILE($1:$100)); ZEILE(A1))))}
B3 : =WENN(A3="";"";ZÄHLENWENN(Tabelle1!A:A;A3))
D3 : {=WENN(ISTFEHLER(KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A1))); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A1))))}
E3 : =WENN(D3="";"";ZÄHLENWENN(Tabelle1!A:A;D3))
A4 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)))<ZEILE(A2); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE($1:$100)); Tabelle1!A$1:A$100)=1;ZEILE($1:$100)); ZEILE(A2))))}
B4 : =WENN(A4="";"";ZÄHLENWENN(Tabelle1!A:A;A4))
D4 : {=WENN(ISTFEHLER(KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A2))); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A2))))}
E4 : =WENN(D4="";"";ZÄHLENWENN(Tabelle1!A:A;D4))
A5 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)))<ZEILE(A3); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE($1:$100)); Tabelle1!A$1:A$100)=1;ZEILE($1:$100)); ZEILE(A3))))}
B5 : =WENN(A5="";"";ZÄHLENWENN(Tabelle1!A:A;A5))
D5 : {=WENN(ISTFEHLER(KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A3))); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A3))))}
E5 : =WENN(D5="";"";ZÄHLENWENN(Tabelle1!A:A;D5))
A6 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)))<ZEILE(A4); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE($1:$100)); Tabelle1!A$1:A$100)=1;ZEILE($1:$100)); ZEILE(A4))))}
B6 : =WENN(A6="";"";ZÄHLENWENN(Tabelle1!A:A;A6))
D6 : {=WENN(ISTFEHLER(KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A4))); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A4))))}
E6 : =WENN(D6="";"";ZÄHLENWENN(Tabelle1!A:A;D6))
A7 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)))<ZEILE(A5); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE($1:$100)); Tabelle1!A$1:A$100)=1;ZEILE($1:$100)); ZEILE(A5))))}
B7 : =WENN(A7="";"";ZÄHLENWENN(Tabelle1!A:A;A7))
D7 : {=WENN(ISTFEHLER(KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A5))); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A5))))}
E7 : =WENN(D7="";"";ZÄHLENWENN(Tabelle1!A:A;D7))
A8 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)))<ZEILE(A6); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE($1:$100)); Tabelle1!A$1:A$100)=1;ZEILE($1:$100)); ZEILE(A6))))}
B8 : =WENN(A8="";"";ZÄHLENWENN(Tabelle1!A:A;A8))
D8 : {=WENN(ISTFEHLER(KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A6))); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A6))))}
E8 : =WENN(D8="";"";ZÄHLENWENN(Tabelle1!A:A;D8))
A9 : {=WENN(SUMME(WENN(Tabelle1!A$1:A$100="";0;1/ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)))<ZEILE(A7); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$1;;;ZEILE($1:$100)); Tabelle1!A$1:A$100)=1;ZEILE($1:$100)); ZEILE(A7))))}
B9 : =WENN(A9="";"";ZÄHLENWENN(Tabelle1!A:A;A9))
D9 : {=WENN(ISTFEHLER(KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A7))); "";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("Tabelle1!A1:A"&ZEILE($1:$100)); Tabelle1!A$1:A$100)=1)*(ZÄHLENWENN(Tabelle1!A$1:A$100;Tabelle1!A$1:A$100)>1); ZEILE($1:$100)); ZEILE(A7))))}
E9 : =WENN(D9="";"";ZÄHLENWENN(Tabelle1!A:A;D9))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
cu jörg
ein feedback wär ganz reizend

Anzeige
hier eine weitere Variante ;o)
17.09.2007 08:27:00
Matthias
Hallo,
im Beispielbild siehst Du die Tabelle2
in Tabelle1 sind in der Spalte A die Werte so hinterlegt, wie Du sie gepostet hast
740
740
965
Apfel
Apfel
Birne
Birne
Birne
Essen5
Essen6
Saft
Bevor Du also den Spezialfilter bemühst,
müssen die Formeln in Tabelle2 A2:A12 und B2:B12 eingetragen werden.
in Tabelle2 Zelle A2 also diese Formel =ZÄHLENWENN(Tabelle1!A:A;Tabelle1!A1) und runterkopieren
in Tabelle2 Zelle B2 also diese Formel =Tabelle1!A1 und runterkopieren
Nachdem die Formeln eingetragen sind, benutze den Spezialfilter
und wenn Du es willst eben einfach noch sortieren.
Da Bilder meist mehr als Worte sagen, hier ist eins ;o)
Userbild
Userbild
Anzeige

333 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige